nbdkit: Update spec for 1.0.0.
[fedora-specs.git] / nbdkit.spec
1 Name:           nbdkit
2 Version:        1.0.0
3 Release:        1%{?dist}
4 Summary:        NBD server
5
6 License:        BSD
7 URL:            https://github.com/libguestfs/nbdkit
8 Source0:        http://libguestfs.org/download/nbdkit/%{name}-%{version}.tar.gz
9
10 BuildRequires:  /usr/bin/pod2man
11 BuildRequires:  libvirt-devel
12 BuildRequires:  xz-devel
13 BuildRequires:  zlib-devel
14
15
16 %description
17 NBD is a protocol for accessing block devices (hard disks and
18 disk-like things) over the network.
19
20 'nbdkit' is a toolkit for creating NBD servers.
21
22 The key features are:
23
24 * Multithreaded NBD server written in C with good performance.
25
26 * Well-documented, simple plugin API with a stable ABI guarantee.
27   Let's you export "unconventional" block devices easily.
28
29 * Liberal license (BSD) allows nbdkit to be linked to proprietary
30   libraries or included in proprietary code.
31
32 Several example plugins are included in the package.
33
34 To develop plugins, install the %{name}-devel package and start by
35 reading the nbdkit(1) and nbdkit-plugin(3) manual pages.
36
37
38 %package devel
39 Summary:        Development files and documentation for %{name}
40 License:        BSD
41
42 Requires:       %{name} = %{version}-%{release}
43
44
45 %description devel
46 This package contains development files and documentation
47 for %{name}.  Install this package if you want to develop
48 plugins for %{name}.
49
50
51 %prep
52 %setup -q
53
54
55 %build
56 %configure --disable-static
57 make %{?_smp_mflags}
58
59
60 %install
61 %make_install
62
63 # Delete libtool crap.
64 find $RPM_BUILD_ROOT -name '*.la' -delete
65
66
67 %files
68 %doc LICENSE README
69 %{_sbindir}/nbdkit
70 %{_libdir}/%{name}
71 %{_mandir}/man1/nbdkit.1*
72 %{_mandir}/man1/nbdkit-*-plugin.1*
73
74
75 %files devel
76 %doc LICENSE README TODO
77 # Include the source of the example plugins in the documentation.
78 %doc plugins/example*/*.c
79 %{_includedir}/nbdkit-plugin.h
80 %{_mandir}/man3/nbdkit-plugin.3*
81
82
83 %changelog
84 * Mon Jun 24 2013 Richard W.M. Jones <rjones@redhat.com> 1.0.0-1
85 - Initial release.