bbc631a04d6e638bfb6d34653f82a533e7f94e97
[fedora-reviews.git] / libblkio / libblkio.spec
1 %global forgeurl https://gitlab.com/libblkio/libblkio
2 %global commit c8f5ed9a1460d90a522bda55da09f013fa7da61c
3 # Upstream has not tagged any versions so far.
4 Version:       0.1
5 %forgemeta
6
7 Summary:       Block device I/O library
8 Name:          libblkio
9 Release:       1%{?dist}
10 URL:           %{forgeurl}
11 Source:        %{forgesource}
12 License:       ASL 2.0 or MIT
13
14 # Basic build requirements.
15 BuildRequires: gcc, gcc-c++
16 BuildRequires: make
17 BuildRequires: meson
18 BuildRequires: rust
19 BuildRequires: rustfmt
20 BuildRequires: cargo
21 BuildRequires: python3-docutils
22 BuildRequires: liburing-devel
23 BuildRequires: pkgconf
24
25
26 %description
27 libblkio is a library for high-performance block device I/O with
28 support for multi-queue devices. A C API is provided so that
29 applications can use the library from most programming languages.
30
31
32 %package devel
33 Summary:       Development tools for %{name}
34 Requires:      %{name}%{_isa} = %{version}-%{release}
35
36
37 %description devel
38 This package contains development tools for %{name}.
39
40
41 %prep
42 %forgesetup
43
44
45 %build
46 %{meson}
47 %{meson_build}
48
49
50 %install
51 %{meson_install}
52
53 pushd %{buildroot}%{_libdir}
54 ln -s libblkio.so libblkio.so.0
55 ln -s libblkio.so.0 libblkio.so.0.0
56 popd
57
58
59 %files
60 %license LICENSE-APACHE LICENSE-MIT LICENSE.crosvm
61 %doc README.rst
62 %{_libdir}/libblkio.so.0*
63
64
65 %files devel
66 %license LICENSE-APACHE LICENSE-MIT LICENSE.crosvm
67 %doc README.rst
68 %{_includedir}/blkio.h
69 %{_libdir}/libblkio.so
70 %{_libdir}/pkgconfig/blkio.pc
71 %{_mandir}/man3/blkio.3*
72
73
74 %changelog
75 * Tue Sep 06 2022 Richard W.M. Jones <rjones@redhat.com> - 0.1-1
76 - Initial package