images: Make a better phony Fedora image.
[libguestfs.git] / tools / Makefile.am
index ab14fe0..651daf9 100644 (file)
@@ -18,7 +18,6 @@
 include $(top_srcdir)/subdir-rules.mk
 
 tools = \
-       cat \
        df \
        edit \
        list-filesystems \
@@ -33,7 +32,6 @@ tools = \
 EXTRA_DIST = \
        run-locally \
        $(tools:%=virt-%) \
-       make-test-img.sh \
        test-virt-*.sh
 
 CLEANFILES = test.img
@@ -44,10 +42,10 @@ bin_SCRIPTS = $(tools:%=virt-%)
 
 # Manual pages and HTML files for the website.
 
-# XXX Bug in automake?  If you list virt-cat.1 explicitly, then it
+# XXX Bug in automake?  If you list virt-df.1 explicitly, then it
 # builds and installs the man pages.  However if this is removed,
 # then the man pages are neither built nor installed.
-man_MANS = virt-cat.1 $(patsubst %,virt-%.1,$(filter-out cat,$(tools)))
+man_MANS = virt-df.1 $(patsubst %,virt-%.1,$(filter-out df,$(tools)))
 
 noinst_DATA = $(tools:%=$(top_builddir)/html/virt-%.1.html)
 
@@ -76,16 +74,11 @@ TESTS_ENVIRONMENT = \
        LIBGUESTFS_PATH=$(top_builddir)/appliance \
        PERL5LIB=$(top_builddir)/perl/blib/lib:$(top_builddir)/perl/blib/arch
 
-# Build a standard test image to be used by all these tests.
-check_DATA = test.img
-test.img: make-test-img.sh
-       $(TESTS_ENVIRONMENT) $(srcdir)/make-test-img.sh
-
-TESTS = test-virt-cat.sh \
-       test-virt-df.sh \
+TESTS = test-virt-df.sh \
        test-virt-list-filesystems.sh \
        test-virt-ls.sh \
        test-virt-make-fs.sh \
+       test-virt-resize.sh \
        test-virt-tar.sh
 
 endif