Move virt tools (virt-cat, virt-edit etc) into tools/ subdirectory.
[libguestfs.git] / tools / Makefile.am
similarity index 64%
rename from cat/Makefile.am
rename to tools/Makefile.am
index 6b9a1bb..d5fc23c 100644 (file)
@@ -1,4 +1,4 @@
-# libguestfs virt-cat
+# libguestfs virt-* tools
 # Copyright (C) 2009 Red Hat Inc.
 #
 # This program is free software; you can redistribute it and/or modify
 # along with this program; if not, write to the Free Software
 # Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
 
+tools = cat df edit rescue
+
 EXTRA_DIST = \
-       run-cat-locally \
-       virt-cat
+       run-locally \
+       $(tools:%=virt-%)
+
+if HAVE_TOOLS
 
-if HAVE_CAT
+bin_SCRIPTS = $(tools:%=virt-%)
 
-bin_SCRIPTS = virt-cat
-man_MANS = virt-cat.1
+# XXX Bug in automake?  If you list virt-cat.1 explicitly, then it
+# builds and installs the man pages.  However if this is removed,
+# then the man pages are neither built nor installed.
+man_MANS = virt-cat.1 $(patsubst %,virt-%.1,$(filter-out cat,$(tools)))
 
-noinst_DATA = $(top_builddir)/html/virt-cat.1.html
+noinst_DATA = $(tools:%=$(top_builddir)/html/virt-%.1.html)
 
-virt-cat.1: virt-cat
+virt-%.1: virt-%
        $(POD2MAN) \
          --section 1 \
          -c "Virtualization Support" \
          --release "$(PACKAGE_NAME)-$(PACKAGE_VERSION)" \
          $< > $@-t && mv $@-t $@
 
-$(top_builddir)/html/virt-cat.1.html: virt-cat
+$(top_builddir)/html/virt-%.1.html: virt-%
        mkdir -p $(top_builddir)/html
        cd $(top_builddir) && pod2html \
          --css 'pod.css' \
-         --title 'virt-cat, display a file in a virtual machine' \
          --htmldir html \
-         --outfile html/virt-cat.1.html \
-         cat/$<
+         --outfile html/$<.1.html \
+         tools/$<
 
 endif