Disable test for RHBZ#576879 comment 5.
[libguestfs.git] / test-tool / Makefile.am
index 510a42f..ee2f2ff 100644 (file)
@@ -15,7 +15,9 @@
 # along with this program; if not, write to the Free Software
 # Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
 
-EXTRA_DIST = libguestfs-test-tool.pod
+include $(top_srcdir)/subdir-rules.mk
+
+EXTRA_DIST = libguestfs-test-tool.pod run-test-tool-locally
 
 CLEANFILES =
 
@@ -28,6 +30,7 @@ AM_CPPFLAGS = \
 
 libguestfs_test_tool_SOURCES = test-tool.c
 libguestfs_test_tool_CFLAGS = \
+       -DLOCALEBASEDIR=\""$(datadir)/locale"\" \
        -I$(top_srcdir)/src -I$(top_builddir)/src \
        -Wall
 libguestfs_test_tool_LDADD = \
@@ -36,6 +39,12 @@ libguestfs_test_tool_LDADD = \
 libguestfs_test_tool_helper_SOURCES = helper.c
 libguestfs_test_tool_helper_LDFLAGS = -all-static
 
+# Build a partly-static library (for the binary distribution).
+
+libguestfs-test-tool.static$(EXEEXT): $(libguestfs_test_tool_OBJECTS) $(libguestfs_test_tool_DEPENDENCIES)
+       $(top_srcdir)/relink-static.sh \
+       $(libguestfs_test_tool_LINK) $(libguestfs_test_tool_OBJECTS) -static $(libguestfs_test_tool_LDADD) $(libguestfs_test_tool_LIBS) -lpcre -lhivex -lmagic -lz
+
 libguestfs-test-tool.1: libguestfs-test-tool.pod
        $(POD2MAN) \
          --section 1 \