gnulib: Add all other libs when linking libguestfs.so.
[libguestfs.git] / src / Makefile.am
index d8a7f55..fa088fe 100644 (file)
 
 include $(top_srcdir)/subdir-rules.mk
 
+CLEANFILES = stamp-guestfs.pod
+
 generator_built = \
        guestfs_protocol.x \
-       guestfs-structs.h \
-       guestfs-actions.h \
+       guestfs.h \
        guestfs-internal-actions.h \
        actions.c \
        bindtests.c \
@@ -47,17 +48,14 @@ EXTRA_DIST = \
        api-support/README \
        api-support/update-from-tarballs.sh
 
-include_HEADERS = guestfs.h guestfs-actions.h guestfs-structs.h
+include_HEADERS = guestfs.h
 
 lib_LTLIBRARIES = libguestfs.la
 
-# This convenience library is solely to avoid compiler warnings
-# in its generated sources.
-libprotocol_la_SOURCES = \
-  guestfs_protocol.c \
-  guestfs_protocol.h
-
-libprotocol_la_CFLAGS =
+# This convenience library is solely to compile its generated sources with
+# custom flags.
+libprotocol_la_SOURCES = guestfs_protocol.c  guestfs_protocol.h
+libprotocol_la_CFLAGS = -Wall -Wno-unused -fno-strict-aliasing
 
 # Build the errnostring perfect hash code.  The generated code has lots
 # of warnings so we must compile it in a separate mini-library.
@@ -120,18 +118,25 @@ libguestfs_la_LDFLAGS += $(VERSION_SCRIPT_FLAGS)libguestfs.syms
 libguestfs_la_SOURCES = \
        guestfs.c \
        guestfs.h \
-       guestfs-actions.h \
        guestfs-internal.h \
-       guestfs-structs.h \
        guestfs_protocol.h \
        gettext.h \
        actions.c \
        appliance.c \
        bindtests.c \
+       dbdump.c \
+       events.c \
        filearch.c \
        inspect.c \
+       inspect_apps.c \
+       inspect_fs.c \
+       inspect_fs_cd.c \
+       inspect_fs_unix.c \
+       inspect_fs_windows.c \
+       inspect_icon.c \
        launch.c \
        listfs.c \
+       match.c \
        proto.c \
        virt.c \
        libguestfs.syms
@@ -139,7 +144,15 @@ libguestfs_la_SOURCES = \
 libguestfs_la_LIBADD = \
        $(HIVEX_LIBS) $(AUGEAS_LIBS) $(PCRE_LIBS) $(MAGIC_LIBS) \
        $(LIBVIRT_LIBS) $(LIBXML2_LIBS) \
-       $(LTLIBTHREAD) ../gnulib/lib/libgnu.la
+       ../gnulib/lib/libgnu.la \
+       $(GETADDRINFO_LIB) \
+       $(HOSTENT_LIB) \
+       $(INET_NTOP_LIB) \
+       $(LIBSOCKET) \
+       $(LIB_CLOCK_GETTIME) \
+       $(LIBINTL) \
+       $(LTLIBTHREAD) \
+       $(SERVENT_LIB)
 
 # Make libguestfs include the convenience libraries.
 noinst_LTLIBRARIES = liberrnostring.la libprotocol.la
@@ -147,6 +160,7 @@ libguestfs_la_LIBADD += liberrnostring.la libprotocol.la
 
 libguestfs_la_CFLAGS = \
   -DGUESTFS_DEFAULT_PATH='"$(libdir)/guestfs"' \
+  -DGUESTFS_WARN_DEPRECATED=1 \
   $(HIVEX_CFLAGS) $(AUGEAS_CFLAGS) $(PCRE_CFLAGS) \
   $(LIBVIRT_CFLAGS) $(LIBXML2_CFLAGS) \
   $(WARN_CFLAGS) $(WERROR_CFLAGS)
@@ -168,38 +182,22 @@ guestfs_protocol.h: guestfs_protocol.x
 endif
 
 # Manual page.
-# guestfs-actions.pod, guestfs-availability.pod and guestfs-structs
-# are autogenerated.  There is no include mechanism for POD, so we
-# have to do it by hand.
 
 man_MANS = guestfs.3 libguestfs.3
+noinst_DATA = $(top_builddir)/html/guestfs.3.html
+
+guestfs.3 $(top_builddir)/html/guestfs.3.html: stamp-guestfs.pod
 
-guestfs.3: guestfs.pod \
+stamp-guestfs.pod: guestfs.pod \
                guestfs-actions.pod \
                guestfs-availability.pod \
                guestfs-structs.pod
-       sed \
-         -e '/@ACTIONS@/rguestfs-actions.pod' \
-         -e 's/@ACTIONS@//' \
-         -e '/@AVAILABILITY@/rguestfs-availability.pod' \
-         -e 's/@AVAILABILITY@//' \
-         -e '/@STRUCTS@/rguestfs-structs.pod' \
-         -e 's/@STRUCTS@//' \
-         < $< | \
-       $(POD2MAN) \
+       $(top_srcdir)/podwrapper.sh \
          --section 3 \
-         -c "Virtualization Support" \
-         --name "guestfs" \
-         --release "$(PACKAGE_NAME)-$(PACKAGE_VERSION)" \
-         > $@
-
-# Check user doesn't try to do 'make all' or 'make check' as root.
-# https://www.redhat.com/archives/libguestfs/2010-April/msg00098.html
-
-all-local: checkroot
-check-local: checkroot
-checkroot:
-       @if [ "`id -u`" = 0 ]; then \
-           echo "*** Error: Don't run 'make' or 'make check' as root."; \
-           exit 1; \
-       fi
+         --man guestfs.3 \
+         --html $(top_builddir)/html/guestfs.3.html \
+         --insert guestfs-actions.pod:@ACTIONS@ \
+         --insert guestfs-availability.pod:@AVAILABILITY@ \
+         --insert guestfs-structs.pod:@STRUCTS@ \
+         $<
+       touch $@