build: new configure-time option: --enable-gcc-warnings
[libguestfs.git] / src / Makefile.am
index 6b1088c..e38c336 100644 (file)
 # along with this program; if not, write to the Free Software
 # Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
 
-EXTRA_DIST = guestfs_protocol.x \
-       guestfs_protocol.c \
-       guestfs_protocol.h
+EXTRA_DIST = \
+       guestfs_protocol.x \
+       MAX_PROC_NR \
+       stamp-generator \
+       generator.ml
 
-EXTRA_DIST += generator.ml
+# Rerun the generator if it has changed.
+# Git removes empty directories, so in cases where the
+# generator is creating the sole file in a directory, we
+# have to create the directory first.
+noinst_DATA = stamp-generator
+
+stamp-generator: generator.ml
+       mkdir -p $(top_srcdir)/perl/lib/Sys
+       mkdir -p $(top_srcdir)/ruby/ext/guestfs
+       mkdir -p $(top_srcdir)/java/com/redhat/et/libguestfs
+       cd $(top_srcdir) && ocaml -warn-error A src/generator.ml
+
+guestfs_protocol.x: stamp-generator
 
 include_HEADERS = guestfs.h guestfs-actions.h guestfs-structs.h
 
 lib_LTLIBRARIES = libguestfs.la
 
+BUILT_SOURCES = \
+  guestfs_protocol.x \
+  guestfs_protocol.c \
+  guestfs_protocol.h \
+  guestfs-structs.h \
+  guestfs-actions.h \
+  guestfs-actions.c \
+  guestfs-bindtests.c
+
+# This convenience library is solely to avoid compiler warnings
+# in its generated sources.
+libprotocol_la_SOURCES = \
+  guestfs_protocol.c \
+  guestfs_protocol.h
+
+libprotocol_la_CFLAGS =
+
+$(BUILT_SOURCES): stamp-generator
+
+CLEANFILES = guestfs_protocol.c guestfs_protocol.h
+
 # From the libtool info file, with comments:
 #
 # |  1. Start with version information of `0:0:0' for each libtool library.
@@ -71,20 +106,28 @@ libguestfs_la_LDFLAGS = -version-info $(MAX_PROC_NR):0:$(MAX_PROC_NR)
 libguestfs_la_SOURCES = \
        guestfs.c \
        guestfs.h \
-       guestfs_protocol.c \
-       guestfs_protocol.h \
        guestfs-actions.h \
        guestfs-actions.c \
        guestfs-bindtests.c \
        gettext.h
 
-libguestfs_la_CFLAGS = -Wall -DGUESTFS_DEFAULT_PATH='"$(libdir)/guestfs"'
+# Make libguestfs include the convenience library.
+noinst_LTLIBRARIES = libprotocol.la
+libguestfs_la_LIBADD = libprotocol.la
+
+libguestfs_la_CFLAGS = \
+  -DGUESTFS_DEFAULT_PATH='"$(libdir)/guestfs"' \
+  $(WARN_CFLAGS) $(WERROR_CFLAGS)
+
+libguestfs_la_CPPFLAGS = -I$(top_srcdir)/gnulib/lib
 
 if HAVE_RPCGEN
 guestfs_protocol.c: guestfs_protocol.x
-       rm -f $@-t
+       rm -f $@-t $@-t2
        $(RPCGEN) -c -o $@-t $<
-       mv $@-t $@
+       sed 's,\.\./\.\./src/,,' < $@-t > $@-t2
+       rm $@-t
+       mv $@-t2 $@
 
 guestfs_protocol.h: guestfs_protocol.x
        rm -f $@-t