Gettextize the source, make library strings translatable.
[libguestfs.git] / src / Makefile.am
index de02622..b41e91a 100644 (file)
 # along with this program; if not, write to the Free Software
 # Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
 
-# NB. guestfs-actions.c is #include'd into guestfs.c, so it should not
-# be listed as a source file.
-EXTRA_DIST = guestfs-actions.c
-
-EXTRA_DIST += guestfs_protocol.x \
+EXTRA_DIST = guestfs_protocol.x \
        guestfs_protocol.c \
        guestfs_protocol.h
 
+EXTRA_DIST += generator.ml
+
 include_HEADERS = guestfs.h guestfs-actions.h guestfs-structs.h
 
 lib_LTLIBRARIES = libguestfs.la
@@ -33,7 +31,9 @@ libguestfs_la_SOURCES = \
        guestfs.h \
        guestfs_protocol.c \
        guestfs_protocol.h \
-       guestfs-actions.h
+       guestfs-actions.h \
+       guestfs-actions.c \
+       gettext.h
 
 libguestfs_la_CFLAGS = -Wall -DGUESTFS_DEFAULT_PATH='"$(libdir)/guestfs"'
 
@@ -47,4 +47,4 @@ guestfs_protocol.h: guestfs_protocol.x
        rm -f $@-t
        $(RPCGEN) -h -o $@-t $<
        mv $@-t $@
-endif
\ No newline at end of file
+endif