avoid compiler warnings about unused vars in generated code
[libguestfs.git] / src / Makefile.am
index 1906378..9eb71b9 100644 (file)
@@ -17,8 +17,6 @@
 
 EXTRA_DIST = \
        guestfs_protocol.x \
-       guestfs_protocol.c \
-       guestfs_protocol.h \
        MAX_PROC_NR \
        stamp-generator \
        generator.ml
@@ -50,8 +48,18 @@ BUILT_SOURCES = \
   guestfs-actions.c \
   guestfs-bindtests.c
 
+# This convenience library is solely to avoid compiler warnings
+# in its generated sources.
+libprotocol_la_SOURCES = \
+  guestfs_protocol.c \
+  guestfs_protocol.h
+
+libprotocol_la_CFLAGS = -Wall -Wno-unused
+
 $(BUILT_SOURCES): stamp-generator
 
+CLEANFILES = guestfs_protocol.c guestfs_protocol.h
+
 # From the libtool info file, with comments:
 #
 # |  1. Start with version information of `0:0:0' for each libtool library.
@@ -98,20 +106,24 @@ libguestfs_la_LDFLAGS = -version-info $(MAX_PROC_NR):0:$(MAX_PROC_NR)
 libguestfs_la_SOURCES = \
        guestfs.c \
        guestfs.h \
-       guestfs_protocol.c \
-       guestfs_protocol.h \
        guestfs-actions.h \
        guestfs-actions.c \
        guestfs-bindtests.c \
        gettext.h
 
+# Make libguestfs include the convenience library.
+noinst_LTLIBRARIES = libprotocol.la
+libguestfs_la_LIBADD = libprotocol.la
+
 libguestfs_la_CFLAGS = -Wall -DGUESTFS_DEFAULT_PATH='"$(libdir)/guestfs"'
 
 if HAVE_RPCGEN
 guestfs_protocol.c: guestfs_protocol.x
-       rm -f $@-t
+       rm -f $@-t $@-t2
        $(RPCGEN) -c -o $@-t $<
-       mv $@-t $@
+       sed 's,\.\./\.\./src/,,' < $@-t > $@-t2
+       rm $@-t
+       mv $@-t2 $@
 
 guestfs_protocol.h: guestfs_protocol.x
        rm -f $@-t