Generate a dummy 'Fedora' fedora.img in images directory for use by tests.
[libguestfs.git] / src / Makefile.am
index 7b88d8b..8781274 100644 (file)
@@ -19,29 +19,34 @@ include $(top_srcdir)/subdir-rules.mk
 
 generator_built = \
        guestfs_protocol.x \
-       guestfs-structs.h \
-       guestfs-actions.h \
+       guestfs.h
        guestfs-internal-actions.h \
        actions.c \
        bindtests.c \
+       errnostring_gperf.gperf \
+       errnostring.c \
+       errnostring.h \
        guestfs-actions.pod \
        guestfs-availability.pod \
        guestfs-structs.pod \
        libguestfs.syms
 
 BUILT_SOURCES = \
-  $(generator_built) \
-  guestfs_protocol.c \
-  guestfs_protocol.h
+       $(generator_built) \
+       guestfs_protocol.c \
+       guestfs_protocol.h \
+       errnostring_gperf.c
 
 EXTRA_DIST = \
        $(BUILT_SOURCES) \
        MAX_PROC_NR \
-       generator.ml \
        libguestfs.3 \
-       guestfs.pod
+       guestfs.pod \
+       api-support/added \
+       api-support/README \
+       api-support/update-from-tarballs.sh
 
-include_HEADERS = guestfs.h guestfs-actions.h guestfs-structs.h
+include_HEADERS = guestfs.h
 
 lib_LTLIBRARIES = libguestfs.la
 
@@ -53,6 +58,19 @@ libprotocol_la_SOURCES = \
 
 libprotocol_la_CFLAGS =
 
+# Build the errnostring perfect hash code.  The generated code has lots
+# of warnings so we must compile it in a separate mini-library.
+liberrnostring_la_SOURCES = \
+       errnostring_gperf.c \
+       errnostring.h \
+       errnostring.c
+liberrnostring_la_CFLAGS =
+
+errnostring_gperf.c: errnostring_gperf.gperf
+       rm -f $@
+       $(GPERF) -t $< > $@-t
+       mv $@-t $@
+
 # From the libtool info file, with comments:
 #
 # |  1. Start with version information of `0:0:0' for each libtool library.
@@ -101,28 +119,33 @@ libguestfs_la_LDFLAGS += $(VERSION_SCRIPT_FLAGS)libguestfs.syms
 libguestfs_la_SOURCES = \
        guestfs.c \
        guestfs.h \
-       guestfs-actions.h \
        guestfs-internal.h \
-       guestfs-structs.h \
        guestfs_protocol.h \
        gettext.h \
        actions.c \
        appliance.c \
        bindtests.c \
+       filearch.c \
        inspect.c \
        launch.c \
+       listfs.c \
        proto.c \
+       virt.c \
        libguestfs.syms
 
-libguestfs_la_LIBADD = $(HIVEX_LIBS) $(LIBPCRE) $(LIBMAGIC) $(LTLIBTHREAD) ../gnulib/lib/libgnu.la
+libguestfs_la_LIBADD = \
+       $(HIVEX_LIBS) $(AUGEAS_LIBS) $(PCRE_LIBS) $(MAGIC_LIBS) \
+       $(LIBVIRT_LIBS) $(LIBXML2_LIBS) \
+       $(LTLIBTHREAD) ../gnulib/lib/libgnu.la
 
-# Make libguestfs include the convenience library.
-noinst_LTLIBRARIES = libprotocol.la
-libguestfs_la_LIBADD += libprotocol.la
+# Make libguestfs include the convenience libraries.
+noinst_LTLIBRARIES = liberrnostring.la libprotocol.la
+libguestfs_la_LIBADD += liberrnostring.la libprotocol.la
 
 libguestfs_la_CFLAGS = \
   -DGUESTFS_DEFAULT_PATH='"$(libdir)/guestfs"' \
-  $(HIVEX_CFLAGS) \
+  $(HIVEX_CFLAGS) $(AUGEAS_CFLAGS) $(PCRE_CFLAGS) \
+  $(LIBVIRT_CFLAGS) $(LIBXML2_CFLAGS) \
   $(WARN_CFLAGS) $(WERROR_CFLAGS)
 
 libguestfs_la_CPPFLAGS = -I$(top_srcdir)/gnulib/lib
@@ -142,7 +165,7 @@ guestfs_protocol.h: guestfs_protocol.x
 endif
 
 # Manual page.
-# guestfs-actions.pod, guestfs-availability.pod and guestfs-structs
+# guestfs-actions.pod, guestfs-availability.pod and guestfs-structs.pod
 # are autogenerated.  There is no include mechanism for POD, so we
 # have to do it by hand.