inspect: Abstract the wrapper that sets up Augeas.
[libguestfs.git] / src / Makefile.am
index cc01459..79ec1d0 100644 (file)
@@ -1,5 +1,5 @@
 # libguestfs
-# Copyright (C) 2009 Red Hat Inc.
+# Copyright (C) 2010 Red Hat Inc.
 #
 # This program is free software; you can redistribute it and/or modify
 # it under the terms of the GNU General Public License as published by
@@ -19,48 +19,34 @@ include $(top_srcdir)/subdir-rules.mk
 
 generator_built = \
        guestfs_protocol.x \
-       guestfs-structs.h \
-       guestfs-actions.h \
+       guestfs.h \
        guestfs-internal-actions.h \
        actions.c \
        bindtests.c \
+       errnostring_gperf.gperf \
+       errnostring.c \
+       errnostring.h \
        guestfs-actions.pod \
        guestfs-availability.pod \
        guestfs-structs.pod \
        libguestfs.syms
 
-$(generator_built): stamp-generator
-
 BUILT_SOURCES = \
-  $(generator_built) \
-  guestfs_protocol.c \
-  guestfs_protocol.h
+       $(generator_built) \
+       guestfs_protocol.c \
+       guestfs_protocol.h \
+       errnostring_gperf.c
 
 EXTRA_DIST = \
        $(BUILT_SOURCES) \
        MAX_PROC_NR \
-       stamp-generator \
-       generator.ml \
        libguestfs.3 \
-       guestfs.pod
+       guestfs.pod \
+       api-support/added \
+       api-support/README \
+       api-support/update-from-tarballs.sh
 
-# Rerun the generator if it has changed.
-# Git removes empty directories, so in cases where the
-# generator is creating the sole file in a directory, we
-# have to create the directory first.
-noinst_DATA = stamp-generator
-
-stamp-generator: generator.ml ../images/test.iso
-       mkdir -p $(top_srcdir)/perl/lib/Sys
-       mkdir -p $(top_srcdir)/ruby/ext/guestfs
-       mkdir -p $(top_srcdir)/java/com/redhat/et/libguestfs
-       mkdir -p $(top_srcdir)/csharp
-       cd $(top_srcdir) && ocaml -warn-error A src/generator.ml
-
-../images/test.iso:
-       make -C ../images test.iso
-
-include_HEADERS = guestfs.h guestfs-actions.h guestfs-structs.h
+include_HEADERS = guestfs.h
 
 lib_LTLIBRARIES = libguestfs.la
 
@@ -72,6 +58,19 @@ libprotocol_la_SOURCES = \
 
 libprotocol_la_CFLAGS =
 
+# Build the errnostring perfect hash code.  The generated code has lots
+# of warnings so we must compile it in a separate mini-library.
+liberrnostring_la_SOURCES = \
+       errnostring_gperf.c \
+       errnostring.h \
+       errnostring.c
+liberrnostring_la_CFLAGS =
+
+errnostring_gperf.c: errnostring_gperf.gperf
+       rm -f $@
+       $(GPERF) -t $< > $@-t
+       mv $@-t $@
+
 # From the libtool info file, with comments:
 #
 # |  1. Start with version information of `0:0:0' for each libtool library.
@@ -120,26 +119,33 @@ libguestfs_la_LDFLAGS += $(VERSION_SCRIPT_FLAGS)libguestfs.syms
 libguestfs_la_SOURCES = \
        guestfs.c \
        guestfs.h \
-       guestfs-actions.h \
        guestfs-internal.h \
        guestfs_protocol.h \
        gettext.h \
        actions.c \
+       appliance.c \
        bindtests.c \
+       filearch.c \
        inspect.c \
        launch.c \
+       listfs.c \
        proto.c \
+       virt.c \
        libguestfs.syms
 
-libguestfs_la_LIBADD = $(HIVEX_LIBS) $(LIBPCRE) $(LIBMAGIC) $(LTLIBTHREAD) ../gnulib/lib/libgnu.la
+libguestfs_la_LIBADD = \
+       $(HIVEX_LIBS) $(AUGEAS_LIBS) $(PCRE_LIBS) $(MAGIC_LIBS) \
+       $(LIBVIRT_LIBS) $(LIBXML2_LIBS) \
+       $(LTLIBTHREAD) ../gnulib/lib/libgnu.la
 
-# Make libguestfs include the convenience library.
-noinst_LTLIBRARIES = libprotocol.la
-libguestfs_la_LIBADD += libprotocol.la
+# Make libguestfs include the convenience libraries.
+noinst_LTLIBRARIES = liberrnostring.la libprotocol.la
+libguestfs_la_LIBADD += liberrnostring.la libprotocol.la
 
 libguestfs_la_CFLAGS = \
   -DGUESTFS_DEFAULT_PATH='"$(libdir)/guestfs"' \
-  $(HIVEX_CFLAGS) \
+  $(HIVEX_CFLAGS) $(AUGEAS_CFLAGS) $(PCRE_CFLAGS) \
+  $(LIBVIRT_CFLAGS) $(LIBXML2_CFLAGS) \
   $(WARN_CFLAGS) $(WERROR_CFLAGS)
 
 libguestfs_la_CPPFLAGS = -I$(top_srcdir)/gnulib/lib
@@ -159,7 +165,7 @@ guestfs_protocol.h: guestfs_protocol.x
 endif
 
 # Manual page.
-# guestfs-actions.pod, guestfs-availability.pod and guestfs-structs
+# guestfs-actions.pod, guestfs-availability.pod and guestfs-structs.pod
 # are autogenerated.  There is no include mechanism for POD, so we
 # have to do it by hand.