tools: Specify format of disks (RHBZ#642934,CVE-2010-3851).
[libguestfs.git] / src / Makefile.am
index 7d9220a..4c5468b 100644 (file)
@@ -1,5 +1,5 @@
 # libguestfs
-# Copyright (C) 2009 Red Hat Inc.
+# Copyright (C) 2010 Red Hat Inc.
 #
 # This program is free software; you can redistribute it and/or modify
 # it under the terms of the GNU General Public License as published by
@@ -22,13 +22,12 @@ generator_built = \
        guestfs-structs.h \
        guestfs-actions.h \
        guestfs-internal-actions.h \
-       guestfs-actions.c \
-       guestfs-bindtests.c \
+       actions.c \
+       bindtests.c \
        guestfs-actions.pod \
        guestfs-availability.pod \
-       guestfs-structs.pod
-
-$(generator_built): stamp-generator
+       guestfs-structs.pod \
+       libguestfs.syms
 
 BUILT_SOURCES = \
   $(generator_built) \
@@ -38,21 +37,8 @@ BUILT_SOURCES = \
 EXTRA_DIST = \
        $(BUILT_SOURCES) \
        MAX_PROC_NR \
-       stamp-generator \
-       generator.ml \
-       libguestfs.3
-
-# Rerun the generator if it has changed.
-# Git removes empty directories, so in cases where the
-# generator is creating the sole file in a directory, we
-# have to create the directory first.
-noinst_DATA = stamp-generator
-
-stamp-generator: generator.ml
-       mkdir -p $(top_srcdir)/perl/lib/Sys
-       mkdir -p $(top_srcdir)/ruby/ext/guestfs
-       mkdir -p $(top_srcdir)/java/com/redhat/et/libguestfs
-       cd $(top_srcdir) && ocaml -warn-error A src/generator.ml
+       libguestfs.3 \
+       guestfs.pod
 
 include_HEADERS = guestfs.h guestfs-actions.h guestfs-structs.h
 
@@ -107,19 +93,27 @@ libprotocol_la_CFLAGS =
 #
 # Note that this scheme means the real library version will always be
 # 'libguestfs.so.0.$(MAX_PROC_NR).0'.
-
 libguestfs_la_LDFLAGS = -version-info $(MAX_PROC_NR):0:$(MAX_PROC_NR)
+
+libguestfs_la_LDFLAGS += $(VERSION_SCRIPT_FLAGS)libguestfs.syms
+
 libguestfs_la_SOURCES = \
        guestfs.c \
        guestfs.h \
        guestfs-actions.h \
-       guestfs-actions.c \
-       guestfs-bindtests.c \
        guestfs-internal.h \
+       guestfs-structs.h \
        guestfs_protocol.h \
-       gettext.h
+       gettext.h \
+       actions.c \
+       appliance.c \
+       bindtests.c \
+       inspect.c \
+       launch.c \
+       proto.c \
+       libguestfs.syms
 
-libguestfs_la_LIBADD = $(LTLIBTHREAD)
+libguestfs_la_LIBADD = $(HIVEX_LIBS) $(AUGEAS_LIBS) $(LIBPCRE) $(LIBMAGIC) $(LTLIBTHREAD) ../gnulib/lib/libgnu.la
 
 # Make libguestfs include the convenience library.
 noinst_LTLIBRARIES = libprotocol.la
@@ -127,6 +121,7 @@ libguestfs_la_LIBADD += libprotocol.la
 
 libguestfs_la_CFLAGS = \
   -DGUESTFS_DEFAULT_PATH='"$(libdir)/guestfs"' \
+  $(HIVEX_CFLAGS) $(AUGEAS_CFLAGS) \
   $(WARN_CFLAGS) $(WERROR_CFLAGS)
 
 libguestfs_la_CPPFLAGS = -I$(top_srcdir)/gnulib/lib
@@ -170,3 +165,14 @@ guestfs.3: guestfs.pod \
          --name "guestfs" \
          --release "$(PACKAGE_NAME)-$(PACKAGE_VERSION)" \
          > $@
+
+# Check user doesn't try to do 'make all' or 'make check' as root.
+# https://www.redhat.com/archives/libguestfs/2010-April/msg00098.html
+
+all-local: checkroot
+check-local: checkroot
+checkroot:
+       @if [ "`id -u`" = 0 ]; then \
+           echo "*** Error: Don't run 'make' or 'make check' as root."; \
+           exit 1; \
+       fi