Version 1.5.23.
[libguestfs.git] / src / Makefile.am
index 0776c65..4c5468b 100644 (file)
@@ -1,5 +1,5 @@
 # libguestfs
-# Copyright (C) 2009 Red Hat Inc.
+# Copyright (C) 2010 Red Hat Inc.
 #
 # This program is free software; you can redistribute it and/or modify
 # it under the terms of the GNU General Public License as published by
@@ -29,8 +29,6 @@ generator_built = \
        guestfs-structs.pod \
        libguestfs.syms
 
-$(generator_built): stamp-generator
-
 BUILT_SOURCES = \
   $(generator_built) \
   guestfs_protocol.c \
@@ -39,27 +37,9 @@ BUILT_SOURCES = \
 EXTRA_DIST = \
        $(BUILT_SOURCES) \
        MAX_PROC_NR \
-       stamp-generator \
-       generator.ml \
        libguestfs.3 \
        guestfs.pod
 
-# Rerun the generator if it has changed.
-# Git removes empty directories, so in cases where the
-# generator is creating the sole file in a directory, we
-# have to create the directory first.
-noinst_DATA = stamp-generator
-
-stamp-generator: generator.ml ../images/test.iso
-       mkdir -p $(top_srcdir)/perl/lib/Sys
-       mkdir -p $(top_srcdir)/ruby/ext/guestfs
-       mkdir -p $(top_srcdir)/java/com/redhat/et/libguestfs
-       mkdir -p $(top_srcdir)/csharp
-       cd $(top_srcdir) && ocaml -warn-error A src/generator.ml
-
-../images/test.iso:
-       make -C ../images test.iso
-
 include_HEADERS = guestfs.h guestfs-actions.h guestfs-structs.h
 
 lib_LTLIBRARIES = libguestfs.la
@@ -122,13 +102,18 @@ libguestfs_la_SOURCES = \
        guestfs.h \
        guestfs-actions.h \
        guestfs-internal.h \
+       guestfs-structs.h \
        guestfs_protocol.h \
        gettext.h \
        actions.c \
+       appliance.c \
        bindtests.c \
+       inspect.c \
+       launch.c \
+       proto.c \
        libguestfs.syms
 
-libguestfs_la_LIBADD = $(LTLIBTHREAD) ../gnulib/lib/libgnu.la
+libguestfs_la_LIBADD = $(HIVEX_LIBS) $(AUGEAS_LIBS) $(LIBPCRE) $(LIBMAGIC) $(LTLIBTHREAD) ../gnulib/lib/libgnu.la
 
 # Make libguestfs include the convenience library.
 noinst_LTLIBRARIES = libprotocol.la
@@ -136,6 +121,7 @@ libguestfs_la_LIBADD += libprotocol.la
 
 libguestfs_la_CFLAGS = \
   -DGUESTFS_DEFAULT_PATH='"$(libdir)/guestfs"' \
+  $(HIVEX_CFLAGS) $(AUGEAS_CFLAGS) \
   $(WARN_CFLAGS) $(WERROR_CFLAGS)
 
 libguestfs_la_CPPFLAGS = -I$(top_srcdir)/gnulib/lib