lib: Expose errno through new API guestfs_last_errno.
[libguestfs.git] / src / Makefile.am
index 68ee693..4bcf7e9 100644 (file)
@@ -1,5 +1,5 @@
 # libguestfs
-# Copyright (C) 2009 Red Hat Inc.
+# Copyright (C) 2010 Red Hat Inc.
 #
 # This program is free software; you can redistribute it and/or modify
 # it under the terms of the GNU General Public License as published by
@@ -22,41 +22,28 @@ generator_built = \
        guestfs-structs.h \
        guestfs-actions.h \
        guestfs-internal-actions.h \
-       guestfs-actions.c \
-       guestfs-bindtests.c \
+       actions.c \
+       bindtests.c \
+       errnostring_gperf.gperf \
+       errnostring.c \
+       errnostring.h
        guestfs-actions.pod \
        guestfs-availability.pod \
        guestfs-structs.pod \
        libguestfs.syms
 
-$(generator_built): stamp-generator
-
 BUILT_SOURCES = \
-  $(generator_built) \
-  guestfs_protocol.c \
-  guestfs_protocol.h
+       $(generator_built) \
+       guestfs_protocol.c \
+       guestfs_protocol.h \
+       errnostring_gperf.c
 
 EXTRA_DIST = \
        $(BUILT_SOURCES) \
        MAX_PROC_NR \
-       stamp-generator \
-       generator.ml \
        libguestfs.3 \
        guestfs.pod
 
-# Rerun the generator if it has changed.
-# Git removes empty directories, so in cases where the
-# generator is creating the sole file in a directory, we
-# have to create the directory first.
-noinst_DATA = stamp-generator
-
-stamp-generator: generator.ml
-       mkdir -p $(top_srcdir)/perl/lib/Sys
-       mkdir -p $(top_srcdir)/ruby/ext/guestfs
-       mkdir -p $(top_srcdir)/java/com/redhat/et/libguestfs
-       mkdir -p $(top_srcdir)/csharp
-       cd $(top_srcdir) && ocaml -warn-error A src/generator.ml
-
 include_HEADERS = guestfs.h guestfs-actions.h guestfs-structs.h
 
 lib_LTLIBRARIES = libguestfs.la
@@ -69,6 +56,19 @@ libprotocol_la_SOURCES = \
 
 libprotocol_la_CFLAGS =
 
+# Build the errnostring perfect hash code.  The generated code has lots
+# of warnings so we must compile it in a separate mini-library.
+liberrnostring_la_SOURCES = \
+       errnostring_gperf.c \
+       errnostring.h \
+       errnostring.c
+liberrnostring_la_CFLAGS =
+
+errnostring_gperf.c: errnostring_gperf.gperf
+       rm -f $@
+       $(GPERF) -t $< > $@-t
+       mv $@-t $@
+
 # From the libtool info file, with comments:
 #
 # |  1. Start with version information of `0:0:0' for each libtool library.
@@ -118,21 +118,27 @@ libguestfs_la_SOURCES = \
        guestfs.c \
        guestfs.h \
        guestfs-actions.h \
-       guestfs-actions.c \
-       guestfs-bindtests.c \
        guestfs-internal.h \
+       guestfs-structs.h \
        guestfs_protocol.h \
        gettext.h \
+       actions.c \
+       appliance.c \
+       bindtests.c \
+       inspect.c \
+       launch.c \
+       proto.c \
        libguestfs.syms
 
-libguestfs_la_LIBADD = $(LTLIBTHREAD)
+libguestfs_la_LIBADD = $(HIVEX_LIBS) $(AUGEAS_LIBS) $(LIBPCRE) $(LIBMAGIC) $(LTLIBTHREAD) ../gnulib/lib/libgnu.la
 
-# Make libguestfs include the convenience library.
-noinst_LTLIBRARIES = libprotocol.la
-libguestfs_la_LIBADD += libprotocol.la
+# Make libguestfs include the convenience libraries.
+noinst_LTLIBRARIES = liberrnostring.la libprotocol.la
+libguestfs_la_LIBADD += liberrnostring.la libprotocol.la
 
 libguestfs_la_CFLAGS = \
   -DGUESTFS_DEFAULT_PATH='"$(libdir)/guestfs"' \
+  $(HIVEX_CFLAGS) $(AUGEAS_CFLAGS) \
   $(WARN_CFLAGS) $(WERROR_CFLAGS)
 
 libguestfs_la_CPPFLAGS = -I$(top_srcdir)/gnulib/lib
@@ -176,3 +182,14 @@ guestfs.3: guestfs.pod \
          --name "guestfs" \
          --release "$(PACKAGE_NAME)-$(PACKAGE_VERSION)" \
          > $@
+
+# Check user doesn't try to do 'make all' or 'make check' as root.
+# https://www.redhat.com/archives/libguestfs/2010-April/msg00098.html
+
+all-local: checkroot
+check-local: checkroot
+checkroot:
+       @if [ "`id -u`" = 0 ]; then \
+           echo "*** Error: Don't run 'make' or 'make check' as root."; \
+           exit 1; \
+       fi