build: Centralize all POD manipulation in 'podwrapper.sh' script.
[libguestfs.git] / src / Makefile.am
index 4bcf7e9..4827e27 100644 (file)
 
 include $(top_srcdir)/subdir-rules.mk
 
+CLEANFILES = stamp-guestfs.pod
+
 generator_built = \
        guestfs_protocol.x \
-       guestfs-structs.h \
-       guestfs-actions.h \
+       guestfs.h \
        guestfs-internal-actions.h \
        actions.c \
        bindtests.c \
        errnostring_gperf.gperf \
        errnostring.c \
-       errnostring.h
+       errnostring.h \
        guestfs-actions.pod \
        guestfs-availability.pod \
        guestfs-structs.pod \
@@ -42,9 +43,12 @@ EXTRA_DIST = \
        $(BUILT_SOURCES) \
        MAX_PROC_NR \
        libguestfs.3 \
-       guestfs.pod
+       guestfs.pod \
+       api-support/added \
+       api-support/README \
+       api-support/update-from-tarballs.sh
 
-include_HEADERS = guestfs.h guestfs-actions.h guestfs-structs.h
+include_HEADERS = guestfs.h
 
 lib_LTLIBRARIES = libguestfs.la
 
@@ -117,20 +121,24 @@ libguestfs_la_LDFLAGS += $(VERSION_SCRIPT_FLAGS)libguestfs.syms
 libguestfs_la_SOURCES = \
        guestfs.c \
        guestfs.h \
-       guestfs-actions.h \
        guestfs-internal.h \
-       guestfs-structs.h \
        guestfs_protocol.h \
        gettext.h \
        actions.c \
        appliance.c \
        bindtests.c \
+       filearch.c \
        inspect.c \
        launch.c \
+       listfs.c \
        proto.c \
+       virt.c \
        libguestfs.syms
 
-libguestfs_la_LIBADD = $(HIVEX_LIBS) $(AUGEAS_LIBS) $(LIBPCRE) $(LIBMAGIC) $(LTLIBTHREAD) ../gnulib/lib/libgnu.la
+libguestfs_la_LIBADD = \
+       $(HIVEX_LIBS) $(AUGEAS_LIBS) $(PCRE_LIBS) $(MAGIC_LIBS) \
+       $(LIBVIRT_LIBS) $(LIBXML2_LIBS) \
+       $(LTLIBTHREAD) ../gnulib/lib/libgnu.la
 
 # Make libguestfs include the convenience libraries.
 noinst_LTLIBRARIES = liberrnostring.la libprotocol.la
@@ -138,7 +146,8 @@ libguestfs_la_LIBADD += liberrnostring.la libprotocol.la
 
 libguestfs_la_CFLAGS = \
   -DGUESTFS_DEFAULT_PATH='"$(libdir)/guestfs"' \
-  $(HIVEX_CFLAGS) $(AUGEAS_CFLAGS) \
+  $(HIVEX_CFLAGS) $(AUGEAS_CFLAGS) $(PCRE_CFLAGS) \
+  $(LIBVIRT_CFLAGS) $(LIBXML2_CFLAGS) \
   $(WARN_CFLAGS) $(WERROR_CFLAGS)
 
 libguestfs_la_CPPFLAGS = -I$(top_srcdir)/gnulib/lib
@@ -158,30 +167,25 @@ guestfs_protocol.h: guestfs_protocol.x
 endif
 
 # Manual page.
-# guestfs-actions.pod, guestfs-availability.pod and guestfs-structs
-# are autogenerated.  There is no include mechanism for POD, so we
-# have to do it by hand.
 
 man_MANS = guestfs.3 libguestfs.3
+noinst_DATA = $(top_builddir)/html/guestfs.3.html
+
+guestfs.3 $(top_builddir)/html/guestfs.3.html: stamp-guestfs.pod
 
-guestfs.3: guestfs.pod \
+stamp-guestfs.pod: guestfs.pod \
                guestfs-actions.pod \
                guestfs-availability.pod \
                guestfs-structs.pod
-       sed \
-         -e '/@ACTIONS@/rguestfs-actions.pod' \
-         -e 's/@ACTIONS@//' \
-         -e '/@AVAILABILITY@/rguestfs-availability.pod' \
-         -e 's/@AVAILABILITY@//' \
-         -e '/@STRUCTS@/rguestfs-structs.pod' \
-         -e 's/@STRUCTS@//' \
-         < $< | \
-       $(POD2MAN) \
+       $(top_srcdir)/podwrapper.sh \
          --section 3 \
-         -c "Virtualization Support" \
-         --name "guestfs" \
-         --release "$(PACKAGE_NAME)-$(PACKAGE_VERSION)" \
-         > $@
+         --man guestfs.3 \
+         --html $(top_builddir)/html/guestfs.3.html \
+         --insert guestfs-actions.pod:@ACTIONS@ \
+         --insert guestfs-availability.pod:@AVAILABILITY@ \
+         --insert guestfs-structs.pod:@STRUCTS@ \
+         $<
+       touch $@
 
 # Check user doesn't try to do 'make all' or 'make check' as root.
 # https://www.redhat.com/archives/libguestfs/2010-April/msg00098.html