build: Remove check for root.
[libguestfs.git] / src / Makefile.am
index 4827e27..2b9c49b 100644 (file)
@@ -186,14 +186,3 @@ stamp-guestfs.pod: guestfs.pod \
          --insert guestfs-structs.pod:@STRUCTS@ \
          $<
        touch $@
-
-# Check user doesn't try to do 'make all' or 'make check' as root.
-# https://www.redhat.com/archives/libguestfs/2010-April/msg00098.html
-
-all-local: checkroot
-check-local: checkroot
-checkroot:
-       @if [ "`id -u`" = 0 ]; then \
-           echo "*** Error: Don't run 'make' or 'make check' as root."; \
-           exit 1; \
-       fi