build: don't tell "make clean" to remove my '~' backup files
[libguestfs.git] / src / Makefile.am
index 68cabba..1874899 100644 (file)
 # along with this program; if not, write to the Free Software
 # Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
 
-lib_LTLIBRARIES = libguestfs.la
+EXTRA_DIST = guestfs_protocol.x \
+       guestfs_protocol.c \
+       guestfs_protocol.h
+
+EXTRA_DIST += generator.ml
 
-# NB. guestfs-actions.c is #include'd into guestfs.c, so it should not
-# be listed as a source file.
-EXTRA_DIST = guestfs-actions.c
+include_HEADERS = guestfs.h guestfs-actions.h guestfs-structs.h
+
+lib_LTLIBRARIES = libguestfs.la
 
+libguestfs_la_LDFLAGS = -version-info 0:0:0
 libguestfs_la_SOURCES = \
        guestfs.c \
        guestfs.h \
        guestfs_protocol.c \
        guestfs_protocol.h \
-       guestfs-actions.h
+       guestfs-actions.h \
+       guestfs-actions.c
 
-libguestfs_la_CFLAGS = -Wall
+libguestfs_la_CFLAGS = -Wall -DGUESTFS_DEFAULT_PATH='"$(libdir)/guestfs"'
 
-if RPCGEN
+if HAVE_RPCGEN
 guestfs_protocol.c: guestfs_protocol.x
        rm -f $@-t
        $(RPCGEN) -c -o $@-t $<
@@ -40,4 +46,4 @@ guestfs_protocol.h: guestfs_protocol.x
        rm -f $@-t
        $(RPCGEN) -h -o $@-t $<
        mv $@-t $@
-endif
\ No newline at end of file
+endif