Version 1.0.52.
[libguestfs.git] / src / Makefile.am
index 9868b42..06d4522 100644 (file)
@@ -17,7 +17,8 @@
 
 EXTRA_DIST = guestfs_protocol.x \
        guestfs_protocol.c \
-       guestfs_protocol.h
+       guestfs_protocol.h \
+       MAX_PROC_NR
 
 EXTRA_DIST += generator.ml
 
@@ -25,14 +26,58 @@ include_HEADERS = guestfs.h guestfs-actions.h guestfs-structs.h
 
 lib_LTLIBRARIES = libguestfs.la
 
-libguestfs_la_LDFLAGS = -version-info 0:0:0
+# From the libtool info file, with comments:
+#
+# |  1. Start with version information of `0:0:0' for each libtool library.
+# |
+# |  2. Update the version information only immediately before a public
+# |     release of your software.  More frequent updates are unnecessary,
+# |     and only guarantee that the current interface number gets larger
+# |     faster.
+# |
+# |  3. If the library source code has changed at all since the last
+# |     update, then increment REVISION (`C:R:A' becomes `C:r+1:A').
+#
+# [So it seems like we should always update the middle 'R' field
+# for any release.]
+#
+# |  4. If any interfaces have been added, removed, or changed since the
+# |     last update, increment CURRENT, and set REVISION to 0.
+# |
+# |  5. If any interfaces have been added since the last public release,
+# |     then increment AGE.
+#
+# [These two rules seem to mean that if any change is made to the
+# generator, we should increment C and A, and set R to 0, so:
+# C+1:0:A+1.]
+#
+# |  6. If any interfaces have been removed since the last public release,
+# |     then set AGE to 0.
+#
+# [Our ABI guarantee means we won't remove interfaces except in
+# very exceptional circumstances.]
+#
+# The maximum proc number (see guestfs_protocol.x:guestfs_procedure) is
+# a mostly accurate stand-in for C & A in rules 5 & 6, so we use that.  It
+# is always incremented when we add a new appliance interface, and easy to
+# calculate.
+#
+# The middle number is hard to increment-and-reset as described in rules
+# 4 & 5, so for the moment it is always set to 0.
+#
+# Note that this scheme means the real library version will always be
+# 'libguestfs.so.0.$(MAX_PROC_NR).0'.
+
+libguestfs_la_LDFLAGS = -version-info $(MAX_PROC_NR):0:$(MAX_PROC_NR)
 libguestfs_la_SOURCES = \
        guestfs.c \
        guestfs.h \
        guestfs_protocol.c \
        guestfs_protocol.h \
        guestfs-actions.h \
-       guestfs-actions.c
+       guestfs-actions.c \
+       guestfs-bindtests.c \
+       gettext.h
 
 libguestfs_la_CFLAGS = -Wall -DGUESTFS_DEFAULT_PATH='"$(libdir)/guestfs"'
 
@@ -47,5 +92,3 @@ guestfs_protocol.h: guestfs_protocol.x
        $(RPCGEN) -h -o $@-t $<
        mv $@-t $@
 endif
-
-CLEANFILES = *~