build: Fix automake warnings
[libguestfs.git] / sparsify / Makefile.am
index 973bcb5..9d5e076 100644 (file)
@@ -17,6 +17,8 @@
 
 include $(top_srcdir)/subdir-rules.mk
 
+SOURCES =
+
 EXTRA_DIST = \
        $(SOURCES) \
        virt-sparsify.pod \
@@ -27,7 +29,7 @@ CLEANFILES = *~ *.cmi *.cmo *.cmx *.cmxa *.o virt-sparsify test.img
 if HAVE_OCAML
 
 # Alphabetical order.
-SOURCES = \
+SOURCES += \
        progress_c.c \
        progress.mli \
        progress.ml \
@@ -113,10 +115,10 @@ depend: .depend
 
 include .depend
 
-.PHONY: depend docs
-
 endif
 
+.PHONY: depend docs
+
 # Parallel builds don't obey dependencies for some reason we
 # don't understand.
 .NOTPARALLEL: