Disable test for RHBZ#576879 comment 5.
[libguestfs.git] / ruby / Makefile.am
index 2b4b201..82d130d 100644 (file)
 # along with this program; if not, write to the Free Software
 # Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
 
+include $(top_srcdir)/subdir-rules.mk
+
+generator_built = \
+       ext/guestfs/_guestfs.c \
+       bindtests.rb
+
 EXTRA_DIST = \
+       $(generator_built) \
        Rakefile.in \
-       ext/guestfs/_guestfs.c \
        ext/guestfs/extconf.rb \
        lib/guestfs.rb \
+       run-bindtests \
        run-ruby-tests \
        tests/tc_*.rb
 
-CLEANFILES = *~ \
+CLEANFILES = \
        lib/*~ \
        tests/*~ \
        ext/guestfs/*~ \
@@ -35,9 +42,13 @@ CLEANFILES = *~ \
 
 if HAVE_RUBY
 
-TESTS = run-ruby-tests
+TESTS = run-bindtests run-ruby-tests
+
+TESTS_ENVIRONMENT = \
+       LD_LIBRARY_PATH=$(top_builddir)/src/.libs \
+       LIBGUESTFS_PATH=$(top_builddir)/appliance
 
-all:
+all: $(generator_built)
        rake build
 
-endif
\ No newline at end of file
+endif