More misc fixes to non-srcdir builds.
[libguestfs.git] / ruby / Makefile.am
index 2b4b201..7ea0107 100644 (file)
@@ -20,10 +20,12 @@ EXTRA_DIST = \
        ext/guestfs/_guestfs.c \
        ext/guestfs/extconf.rb \
        lib/guestfs.rb \
+       run-bindtests \
        run-ruby-tests \
+       bindtests.rb \
        tests/tc_*.rb
 
-CLEANFILES = *~ \
+CLEANFILES = \
        lib/*~ \
        tests/*~ \
        ext/guestfs/*~ \
@@ -35,9 +37,13 @@ CLEANFILES = *~ \
 
 if HAVE_RUBY
 
-TESTS = run-ruby-tests
+TESTS = run-bindtests run-ruby-tests
+
+TESTS_ENVIRONMENT = \
+       LD_LIBRARY_PATH=$(top_builddir)/src/.libs \
+       LIBGUESTFS_PATH=$(top_builddir)/appliance
 
 all:
        rake build
 
-endif
\ No newline at end of file
+endif