Fix detection of optional libvirt support in virt-inspector.
[libguestfs.git] / ruby / Makefile.am
index 9ee0ae5..389399f 100644 (file)
@@ -20,7 +20,9 @@ EXTRA_DIST = \
        ext/guestfs/_guestfs.c \
        ext/guestfs/extconf.rb \
        lib/guestfs.rb \
+       run-bindtests \
        run-ruby-tests \
+       bindtests.rb \
        tests/tc_*.rb
 
 CLEANFILES = \
@@ -35,7 +37,11 @@ CLEANFILES = \
 
 if HAVE_RUBY
 
-TESTS = run-ruby-tests
+TESTS = run-bindtests run-ruby-tests
+
+TESTS_ENVIRONMENT = \
+       LD_LIBRARY_PATH=../src/.libs \
+       LIBGUESTFS_PATH=../appliance
 
 all:
        rake build