Stable OCaml dependencies.
[libguestfs.git] / resize / Makefile.am
index 93c193e..ff10cf8 100644 (file)
@@ -19,7 +19,6 @@ include $(top_srcdir)/subdir-rules.mk
 
 EXTRA_DIST = \
        $(SOURCES) \
-       run-resize-locally \
        virt-resize.pod \
        test-virt-resize.sh
 
@@ -30,24 +29,33 @@ if HAVE_OCAML_PCRE
 
 # Alphabetical order.
 SOURCES = \
+       progress_c.c \
+       progress.mli \
        progress.ml \
        resize.ml \
        utils.ml
 
 # Note this list must be in dependency order.
 OBJECTS = \
+       ../fish/guestfish-progress.o \
+       progress_c.o \
        utils.cmx \
        progress.cmx \
        resize.cmx
 
 bin_SCRIPTS = virt-resize
 
-OCAMLPACKAGES = -package pcre -I ../ocaml
+# -I $(top_builddir)/src/.libs is a hack which forces corresponding -L
+# option to be passed to gcc, so we don't try linking against an
+# installed copy of libguestfs.
+OCAMLPACKAGES = -package pcre -I $(top_builddir)/src/.libs -I ../ocaml
+
 OCAMLCFLAGS = -g -warn-error CDEFLMPSUVYZX $(OCAMLPACKAGES)
 OCAMLOPTFLAGS = $(OCAMLCFLAGS)
 
 virt-resize: $(OBJECTS)
-       $(OCAMLFIND) ocamlopt $(OCAMLOPTFLAGS) mlguestfs.cmxa -linkpkg $^ -o $@
+       $(OCAMLFIND) ocamlopt $(OCAMLOPTFLAGS) \
+         mlguestfs.cmxa -linkpkg $^ -cclib -lncurses -o $@
 
 .mli.cmi:
        $(OCAMLFIND) ocamlc $(OCAMLCFLAGS) -c $< -o $@
@@ -56,6 +64,14 @@ virt-resize: $(OBJECTS)
 .ml.cmx:
        $(OCAMLFIND) ocamlopt $(OCAMLCFLAGS) -c $< -o $@
 
+# automake will decide we don't need C support in this file.  Really
+# we do, so we have to provide it ourselves.
+
+DEFAULT_INCLUDES = -I. -I$(top_builddir) -I$(shell $(OCAMLC) -where) -I../fish
+
+.c.o:
+       $(CC) $(CFLAGS) $(PROF_CFLAGS) $(DEFAULT_INCLUDES) -c $< -o $@
+
 # Manual pages and HTML files for the website.
 
 man_MANS = virt-resize.1
@@ -65,12 +81,14 @@ noinst_DATA = $(top_builddir)/html/virt-resize.1.html
 virt-resize.1 $(top_builddir)/html/virt-resize.1.html: stamp-virt-resize.pod
 
 stamp-virt-resize.pod: virt-resize.pod
-       $(top_srcdir)/podwrapper.sh \
+       $(top_builddir)/podwrapper.sh \
          --man virt-resize.1 \
          --html $(top_builddir)/html/virt-resize.1.html \
          $<
        touch $@
 
+CLEANFILES += stamp-virt-resize.pod
+
 # Tests.
 
 random_val := $(shell awk 'BEGIN{srand(); print 1+int(255*rand())}' < /dev/null)
@@ -78,7 +96,8 @@ random_val := $(shell awk 'BEGIN{srand(); print 1+int(255*rand())}' < /dev/null)
 TESTS_ENVIRONMENT = \
        MALLOC_PERTURB_=$(random_val) \
        LD_LIBRARY_PATH=$(top_builddir)/src/.libs \
-       LIBGUESTFS_PATH=$(top_builddir)/appliance
+       LIBGUESTFS_PATH=$(top_builddir)/appliance \
+       TMPDIR=$(top_builddir)
 
 TESTS = test-virt-resize.sh
 
@@ -87,7 +106,8 @@ depend: .depend
 
 .depend: $(wildcard *.mli) $(wildcard *.ml)
        rm -f $@ $@-t
-       $(OCAMLFIND) ocamldep $(OCAMLPACKAGES) $^ | \
+       $(OCAMLFIND) ocamldep $^ | \
+         $(SED) 's/ *$$//' | \
          $(SED) -e :a -e '/ *\\$$/N; s/ *\\\n */ /; ta' | \
          sort > $@-t
        mv $@-t $@