Ubuntu: Fix compilation of virt-resize if old libguestfs already installed.
[libguestfs.git] / resize / Makefile.am
index f3e6aff..8418cb4 100644 (file)
@@ -41,7 +41,11 @@ OBJECTS = \
 
 bin_SCRIPTS = virt-resize
 
-OCAMLPACKAGES = -package pcre -I ../ocaml
+# -I $(top_builddir)/src/.libs is a hack which forces corresponding -L
+# option to be passed to gcc, so we don't try linking against an
+# installed copy of libguestfs.
+OCAMLPACKAGES = -package pcre -I $(top_builddir)/src/.libs -I ../ocaml
+
 OCAMLCFLAGS = -g -warn-error CDEFLMPSUVYZX $(OCAMLPACKAGES)
 OCAMLOPTFLAGS = $(OCAMLCFLAGS)