build: Set TMPDIR for local testing.
[libguestfs.git] / regressions / Makefile.am
index ca4292a..c00a615 100644 (file)
@@ -1,5 +1,5 @@
 # libguestfs
-# Copyright (C) 2009 Red Hat Inc.
+# Copyright (C) 2009-2011 Red Hat Inc.
 #
 # This program is free software; you can redistribute it and/or modify
 # it under the terms of the GNU General Public License as published by
@@ -32,10 +32,22 @@ TESTS = \
        rhbz576879.sh \
        rhbz578407.sh \
        rhbz580246.sh \
+       rhbz602997.sh \
+       rhbz690819.sh \
+       test-add-domain.sh \
+       test-both-ends-cancel.sh \
        test-cancellation-download-librarycancels.sh \
        test-cancellation-upload-daemoncancels.sh \
+       test-copy.sh \
        test-find0.sh \
+       test-guestfish-a.sh \
+       test-guestfish-d.sh \
+       test-guestfish-escapes.sh \
+       test-guestfish-tilde.sh \
+       test-inspect-fstab.sh \
+       test-launch-race.pl \
        test-luks.sh \
+       test-luks-list.sh \
        test-lvm-filtering.sh \
        test-lvm-mapping.pl \
        test-noexec-stack.pl \
@@ -45,7 +57,8 @@ TESTS = \
        test-read_file.sh \
        test-remote.sh \
        test-reopen.sh \
-       test-stringlist.sh
+       test-stringlist.sh \
+       test-upload-to-dir.sh
 
 SKIPPED_TESTS = \
        test-bootbootboot.sh
@@ -59,6 +72,7 @@ TESTS_ENVIRONMENT = \
        MALLOC_PERTURB_=$(random_val) \
        LD_LIBRARY_PATH=$(top_builddir)/src/.libs \
        LIBGUESTFS_PATH=$(top_builddir)/appliance \
+       TMPDIR=$(top_builddir) \
        PERL5LIB=$(top_builddir)/perl/blib/lib:$(top_builddir)/perl/blib/arch \
        NOEXEC_CHECK="$(top_builddir)/src/.libs/libguestfs.so $(top_builddir)/daemon/guestfsd"