Remove old regression test that mainly tested a buggy API.
[libguestfs.git] / regressions / Makefile.am
index 15f6d7b..250fd64 100644 (file)
@@ -1,5 +1,5 @@
 # libguestfs
-# Copyright (C) 2009 Red Hat Inc.
+# Copyright (C) 2009-2011 Red Hat Inc.
 #
 # This program is free software; you can redistribute it and/or modify
 # it under the terms of the GNU General Public License as published by
@@ -26,20 +26,27 @@ include $(top_srcdir)/subdir-rules.mk
 TESTS = \
        tell-user-to-ignore-errors.sh \
        rhbz501893 \
-       rhbz503169c10.sh \
        rhbz503169c13.sh \
        rhbz557655.sh \
+       rhbz576879.sh \
        rhbz578407.sh \
        rhbz580246.sh \
+       rhbz602997.sh \
+       rhbz690819.sh \
        test-add-domain.sh \
+       test-both-ends-cancel.sh \
        test-cancellation-download-librarycancels.sh \
        test-cancellation-upload-daemoncancels.sh \
        test-copy.sh \
        test-find0.sh \
        test-guestfish-a.sh \
        test-guestfish-d.sh \
+       test-guestfish-escapes.sh \
+       test-guestfish-tilde.sh \
+       test-inspect-fstab.sh \
        test-launch-race.pl \
        test-luks.sh \
+       test-luks-list.sh \
        test-lvm-filtering.sh \
        test-lvm-mapping.pl \
        test-noexec-stack.pl \
@@ -49,13 +56,13 @@ TESTS = \
        test-read_file.sh \
        test-remote.sh \
        test-reopen.sh \
-       test-stringlist.sh
+       test-stringlist.sh \
+       test-upload-to-dir.sh
 
 SKIPPED_TESTS = \
        test-bootbootboot.sh
 
 FAILING_TESTS = \
-       rhbz576879.sh \
        test-qemudie-launchfail.sh
 
 random_val := $(shell awk 'BEGIN{srand(); print 1+int(255*rand())}' < /dev/null)
@@ -64,6 +71,7 @@ TESTS_ENVIRONMENT = \
        MALLOC_PERTURB_=$(random_val) \
        LD_LIBRARY_PATH=$(top_builddir)/src/.libs \
        LIBGUESTFS_PATH=$(top_builddir)/appliance \
+       TMPDIR=$(top_builddir) \
        PERL5LIB=$(top_builddir)/perl/blib/lib:$(top_builddir)/perl/blib/arch \
        NOEXEC_CHECK="$(top_builddir)/src/.libs/libguestfs.so $(top_builddir)/daemon/guestfsd"