tests: Rename capitests -> tests/c-api.
[libguestfs.git] / regressions / Makefile.am
index 6527e06..00c25f1 100644 (file)
@@ -1,5 +1,5 @@
 # libguestfs
-# Copyright (C) 2009 Red Hat Inc.
+# Copyright (C) 2009-2011 Red Hat Inc.
 #
 # This program is free software; you can redistribute it and/or modify
 # it under the terms of the GNU General Public License as published by
 #
 # You should have received a copy of the GNU General Public License
 # along with this program; if not, write to the Free Software
-# Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
+# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
 
 # Regression tests and other important tests which are not
 # specific to the C API.  We can write these more easily in
 # higher level languages than C.
-#
-# See also capitests/
 
 include $(top_srcdir)/subdir-rules.mk
 
 TESTS = \
        tell-user-to-ignore-errors.sh \
        rhbz501893 \
-       rhbz503169c10.sh \
        rhbz503169c13.sh \
        rhbz557655.sh \
        rhbz576879.sh \
        rhbz578407.sh \
        rhbz580246.sh \
+       rhbz602997.sh \
+       rhbz690819.sh \
        test-add-domain.sh \
+       test-both-ends-cancel.sh \
        test-cancellation-download-librarycancels.sh \
        test-cancellation-upload-daemoncancels.sh \
        test-copy.sh \
        test-find0.sh \
        test-guestfish-a.sh \
        test-guestfish-d.sh \
+       test-guestfish-escapes.sh \
+       test-guestfish-events.sh \
        test-guestfish-tilde.sh \
        test-inspect-fstab.sh \
+       test-inspect-fstab-md.sh \
        test-launch-race.pl \
+       test-list-filesystems.sh \
+       test-list-md-devices.sh \
        test-luks.sh \
+       test-luks-list.sh \
        test-lvm-filtering.sh \
        test-lvm-mapping.pl \
+       test-mdadm.sh \
        test-noexec-stack.pl \
        test-qemudie-killsub.sh \
        test-qemudie-midcommand.sh \
@@ -59,7 +66,6 @@ SKIPPED_TESTS = \
        test-bootbootboot.sh
 
 FAILING_TESTS = \
-       test-both-ends-cancel.sh \
        test-qemudie-launchfail.sh
 
 random_val := $(shell awk 'BEGIN{srand(); print 1+int(255*rand())}' < /dev/null)
@@ -68,6 +74,7 @@ TESTS_ENVIRONMENT = \
        MALLOC_PERTURB_=$(random_val) \
        LD_LIBRARY_PATH=$(top_builddir)/src/.libs \
        LIBGUESTFS_PATH=$(top_builddir)/appliance \
+       TMPDIR=$(top_builddir) \
        PERL5LIB=$(top_builddir)/perl/blib/lib:$(top_builddir)/perl/blib/arch \
        NOEXEC_CHECK="$(top_builddir)/src/.libs/libguestfs.so $(top_builddir)/daemon/guestfsd"