Version 1.11.19.
[libguestfs.git] / po-docs / ja / Makefile.am
index e088ebb..4b149fe 100644 (file)
@@ -1,5 +1,5 @@
 # libguestfs translations of man pages and POD files
-# Copyright (C) 2010 Red Hat Inc.
+# Copyright (C) 2010-2011 Red Hat Inc.
 #
 # This program is free software; you can redistribute it and/or modify
 # it under the terms of the GNU General Public License as published by
@@ -23,66 +23,55 @@ LINGUA = $(shell basename -- `pwd`)
 
 CLEANFILES = *.1 *.3
 
-# Ship the final translated manpages in the tarball.
 MANPAGES = \
        guestfs.3 \
        guestfish.1 \
+       virt-copy-in.1 \
+       virt-copy-out.1 \
+       virt-tar-in.1 \
+       virt-tar-out.1 \
        libguestfs-test-tool.1 \
        guestmount.1 \
-       $(patsubst %.pl,%.1,$(wildcard virt-*.pl))
+       $(patsubst %.pl,%.1,$(wildcard virt-*.pl)) \
+       virt-cat.1 \
+       virt-df.1 \
+       virt-edit.1 \
+       virt-filesystems.1 \
+       virt-inspector.1 \
+       virt-ls.1 \
+       virt-rescue.1 \
+       virt-resize.1
 
-EXTRA_DIST = $(MANPAGES)
+# Ship the POD files and the translated manpages in the tarball.  This
+# just simplifies building from the tarball, at a small cost in extra
+# size.
+EXTRA_DIST = \
+       $(MANPAGES) \
+       $(shell for f in `cat ../podfiles`; do basename $$f; done)
 
 all-local: $(MANPAGES)
 
 guestfs.3: guestfs.pod guestfs-actions.pod guestfs-availability.pod guestfs-structs.pod
-       sed \
-         -e '/@ACTIONS@/rguestfs-actions.pod' \
-         -e 's/@ACTIONS@//' \
-         -e '/@AVAILABILITY@/rguestfs-availability.pod' \
-         -e 's/@AVAILABILITY@//' \
-         -e '/@STRUCTS@/rguestfs-structs.pod' \
-         -e 's/@STRUCTS@//' \
-       < $< | \
-       $(POD2MAN) -u \
+       $(top_srcdir)/podwrapper.sh \
          --section 3 \
-         -c "Virtualization Support" \
-         --name "guestfs" \
-         --release "$(PACKAGE_NAME)-$(PACKAGE_VERSION)" \
-         > $@-t; mv $@-t $@
+         --man $@ \
+         --insert guestfs-actions.pod:@ACTIONS@ \
+         --insert guestfs-availability.pod:@AVAILABILITY@ \
+         --insert guestfs-structs.pod:@STRUCTS@ \
+         $<
 
-guestfish.1: guestfish.pod guestfish-actions.pod
-       sed \
-         -e '/@ACTIONS@/rguestfish-actions.pod' -e 's/@ACTIONS@//' \
-         < $< | \
-       $(POD2MAN) -u \
-         --section 1 \
-         -c "Virtualization Support" \
-         --name "guestfish" \
-         --release "$(PACKAGE_NAME)-$(PACKAGE_VERSION)" \
-         > $@-t; mv $@-t $@
+guestfish.1: guestfish.pod guestfish-actions.pod guestfish-commands.pod
+       $(top_srcdir)/podwrapper.sh \
+         --man $@ \
+         --insert guestfish-actions.pod:@ACTIONS@ \
+         --insert guestfish-commands.pod:@FISH_COMMANDS@ \
+         $<
 
-guestmount.1: guestmount.pod
-       $(POD2MAN) -u \
-         --section 1 \
-         -c "Virtualization Support" \
-         --name "guestmount" \
-         --release "$(PACKAGE_NAME)-$(PACKAGE_VERSION)" \
-         $< > $@-t; mv $@-t $@
+%.1: %.pod
+       $(top_srcdir)/podwrapper.sh --man $@ $<
 
-libguestfs-test-tool.1: libguestfs-test-tool.pod
-       $(POD2MAN) -u \
-         --section 1 \
-         -c "Virtualization Support" \
-         --release "$(PACKAGE_NAME)-$(PACKAGE_VERSION)" \
-         $< > $@-t; mv $@-t $@
-
-virt-%.1: virt-%.pl
-       $(POD2MAN) -u \
-         --section 1 \
-         -c "Virtualization Support" \
-         --release "$(PACKAGE_NAME)-$(PACKAGE_VERSION)" \
-         $< > $@-t && mv $@-t $@
+%.1: %.pl
+       $(top_srcdir)/podwrapper.sh --man $@ $<
 
 # XXX Can automake do this properly?
 install-data-hook: