build: Don't try to rebuild po-docs/<lang> if no po4a.
[libguestfs.git] / po-docs / ja / Makefile.am
index 83a2340..0082288 100644 (file)
@@ -41,10 +41,10 @@ EXTRA_DIST = \
        libguestfs-test-tool.pod \
        $(wildcard virt-*.pl)
 
-all-local: $(MANPAGES)
-
 if HAVE_PO4A
 
+all-local: $(MANPAGES)
+
 guestfs.3: guestfs.pod guestfs-actions.pod guestfs-availability.pod guestfs-structs.pod
        sed \
          -e '/@ACTIONS@/rguestfs-actions.pod' \
@@ -95,6 +95,10 @@ virt-%.1: virt-%.pl
          --release "$(PACKAGE_NAME)-$(PACKAGE_VERSION)" \
          $< > $@-t && mv $@-t $@
 
+else
+
+all-local:
+
 endif
 
 # XXX Can automake do this properly?