daemon: debug segv correct use of dereferencing NULL.
[libguestfs.git] / po-docs / Makefile.am
index 2827770..f9af41b 100644 (file)
 #
 # You should have received a copy of the GNU General Public License
 # along with this program; if not, write to the Free Software
-# Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
+# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
 
 # XXX The use of po4a is naive here.  Also we should integrate this
 # into the po/ directory and the translations into the usual
 # libguestfs.pot file.
 
 # Languages.
-LINGUAS = ja
+LINGUAS = ja uk
 
 EXTRA_DIST = \
        libguestfs-docs.pot \
@@ -34,20 +34,6 @@ CLEANFILES = po4a.conf
 # XXX Is there a better way?
 SUBDIRS = $(LINGUAS)
 
-# List of english POD sources which can be translated.
-# Perl files count as POD as far as po4a is concerned.
-PODFILES = \
-       ../src/guestfs.pod \
-       ../src/guestfs-actions.pod \
-       ../src/guestfs-availability.pod \
-       ../src/guestfs-structs.pod \
-       ../fish/guestfish.pod \
-       ../fish/guestfish-actions.pod \
-       ../fish/guestfish-commands.pod \
-       ../test-tool/libguestfs-test-tool.pod \
-       ../fuse/guestmount.pod \
-       $(wildcard ../tools/virt-*.pl)
-
 update-po: libguestfs-docs.pot
 
 # Note: po4a leaves empty '=encoding' lines in POD files.  Also it
@@ -64,17 +50,30 @@ libguestfs-docs.pot: po4a.conf
          --copyright-holder "Red Hat Inc." \
          po4a.conf
        for f in `find $(LINGUAS) -name '*.pod' -o -name '*.pl'`; do \
-         awk 'FNR >= 14 { print }' < $$f > $$f.new; \
+         echo '=encoding utf8' > $$f.new; \
+         awk 'FNR >= 14 { print }' < $$f >> $$f.new; \
          mv $$f.new $$f; \
        done
 
-po4a.conf: $(PODFILES)
+po4a.conf: podfiles
        rm -f $@-t
        echo "[po_directory] ." >> $@-t
        echo >> $@-t
-       for f in $(PODFILES); do \
+       for f in `cat podfiles`; do \
          b=`basename -- $$f`; \
          echo "[type: pod] $$f \$$lang:\$$lang/$$b" >> $@-t; \
          echo >> $@-t; \
        done;
        mv $@-t $@
+
+podfiles: Makefile
+       rm -f $@ $@-t
+       find $(top_srcdir) -name '*.pod' | \
+         grep -v /debian/ | \
+         grep -v /libguestfs-1 | \
+         grep -v /po-docs/ | \
+         grep -v /stamp- \
+         > $@-t
+       find $(top_srcdir)/tools -name 'virt-*.pl' >> $@-t
+       LC_ALL=C sort -o $@-t $@-t
+       mv $@-t $@