tests: Split images -> tests/data + tests/guests
[libguestfs.git] / perl / Makefile.am
index b766244..e924cb1 100644 (file)
@@ -13,7 +13,7 @@
 #
 # You should have received a copy of the GNU General Public License
 # along with this program; if not, write to the Free Software
 #
 # You should have received a copy of the GNU General Public License
 # along with this program; if not, write to the Free Software
-# Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
+# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
 
 include $(top_srcdir)/subdir-rules.mk
 
 
 include $(top_srcdir)/subdir-rules.mk
 
@@ -39,15 +39,27 @@ if HAVE_PERL
 # Interfacing automake and ExtUtils::MakeMaker known to be
 # a nightmare, news at 11.
 
 # Interfacing automake and ExtUtils::MakeMaker known to be
 # a nightmare, news at 11.
 
+# src/ dependencies
+.PHONY: src_deps
+src_deps: $(top_builddir)/src/libguestfs.la $(generator_built)
+
+# Images used by tests
+.PHONY: test_images
+test_images:
+       $(MAKE) -C $(top_builddir)/tests/data
+
 TESTS = run-bindtests run-perl-tests
 
 TESTS = run-bindtests run-perl-tests
 
+$(TESTS): src_deps all appliance test_images
+
 TESTS_ENVIRONMENT = \
        LD_LIBRARY_PATH=$(top_builddir)/src/.libs \
 TESTS_ENVIRONMENT = \
        LD_LIBRARY_PATH=$(top_builddir)/src/.libs \
-       LIBGUESTFS_PATH=$(top_builddir)/appliance
+       LIBGUESTFS_PATH=$(top_builddir)/appliance \
+       TMPDIR=$(top_builddir)
 
 INSTALLDIRS = site
 
 
 INSTALLDIRS = site
 
-all: Makefile-pl $(generator_built)
+all: Makefile-pl src_deps
        $(MAKE) -f Makefile-pl
 
 Makefile-pl: Makefile.PL
        $(MAKE) -f Makefile-pl
 
 Makefile-pl: Makefile.PL