Fix dependencies in perl so it doesn't always rebuild
[libguestfs.git] / perl / Makefile.am
index 44ac42c..747ac43 100644 (file)
@@ -41,10 +41,12 @@ TESTS_ENVIRONMENT = \
 
 INSTALLDIRS = site
 
 
 INSTALLDIRS = site
 
-all:
-       perl Makefile.PL INSTALLDIRS=$(INSTALLDIRS) PREFIX=$(prefix)
+all: Makefile-pl
        $(MAKE) -f Makefile-pl
 
        $(MAKE) -f Makefile-pl
 
+Makefile-pl: Makefile.PL
+       perl Makefile.PL INSTALLDIRS=$(INSTALLDIRS) PREFIX=$(prefix)
+
 install-data-hook:
        $(MAKE) -f Makefile-pl DESTDIR=$(DESTDIR) install
 
 install-data-hook:
        $(MAKE) -f Makefile-pl DESTDIR=$(DESTDIR) install