Cleanup initialisation of hash entries in Lib.pm
[libguestfs.git] / perl / Makefile.am
index 7ff52d9..4b7ed99 100644 (file)
@@ -22,25 +22,39 @@ EXTRA_DIST = \
        examples/LICENSE \
        examples/*.pl \
        lib/Sys/Guestfs.pm \
+       lib/Sys/Guestfs/Lib.pm \
+       run-bindtests \
        run-perl-tests \
+       bindtests.pl \
        t/*.t \
        typemap
 
-CLEANFILES = *~ examples/*~ t/*~
-
 if HAVE_PERL
 
 # Interfacing automake and ExtUtils::MakeMaker known to be
 # a nightmare, news at 11.
 
-TESTS = run-perl-tests
+TESTS = run-bindtests run-perl-tests
+
+TESTS_ENVIRONMENT = \
+       LD_LIBRARY_PATH=$(top_builddir)/src/.libs \
+       LIBGUESTFS_PATH=$(top_builddir)/appliance
 
 INSTALLDIRS = site
 
-all:
-       perl Makefile.PL INSTALLDIRS=$(INSTALLDIRS) PREFIX=$(prefix)
+all: Makefile-pl
        $(MAKE) -f Makefile-pl
 
+Makefile-pl: Makefile.PL
+       perl Makefile.PL INSTALLDIRS=$(INSTALLDIRS) PREFIX=$(prefix)
+
+# No!  Otherwise it is deleted before the clean-local rule runs.
+#CLEANFILES = Makefile-pl
+
+clean-local:
+       -$(MAKE) -f Makefile-pl clean
+       rm -f Makefile-pl
+
 install-data-hook:
        $(MAKE) -f Makefile-pl DESTDIR=$(DESTDIR) install