Generated code for 'glob-expand'.
[libguestfs.git] / ocaml / Makefile.am
index ee42134..cb4ad34 100644 (file)
 EXTRA_DIST = \
        guestfs.mli guestfs.ml \
        guestfs_c.c guestfs_c.h guestfs_c_actions.c \
-       .depend META.in
+       .depend META.in \
+       bindtests.ml \
+       run-bindtests \
+       t/*.ml
 
 SUBDIRS = examples
 
-CLEANFILES = *~
+CLEANFILES = *.cmi *.cmo *.cmx *.cma *.cmxa *.o *.a *.so
+CLEANFILES += t/*.cmi t/*.cmo t/*.cmx t/*.o t/*.a t/*.so
 
 if HAVE_OCAML
 
 noinst_DATA = mlguestfs.cma mlguestfs.cmxa META
 
 mlguestfs.cma: guestfs_c.o guestfs_c_actions.o guestfs.cmo
-       $(OCAMLMKLIB) -o mlguestfs $^ -lguestfs
+       $(OCAMLMKLIB) -o mlguestfs $^ -L$(top_builddir)/src/.libs -lguestfs
 
 mlguestfs.cmxa: guestfs_c.o guestfs_c_actions.o guestfs.cmx
-       $(OCAMLMKLIB) -o mlguestfs $^ -lguestfs
+       $(OCAMLMKLIB) -o mlguestfs $^ -L$(top_builddir)/src/.libs -lguestfs
 
 guestfs_c.o: guestfs_c.c
        $(CC) $(CFLAGS) -I$(OCAMLLIB) -I$(top_builddir)/src -fPIC -Wall -c $<
@@ -40,6 +44,28 @@ guestfs_c.o: guestfs_c.c
 guestfs_c_actions.o: guestfs_c_actions.c
        $(CC) $(CFLAGS) -I$(OCAMLLIB) -I$(top_builddir)/src -fPIC -Wall -c $<
 
+TESTS_ENVIRONMENT = \
+       LD_LIBRARY_PATH=$(top_builddir)/src/.libs \
+       LIBGUESTFS_PATH=$(top_builddir)/appliance \
+       $(VG)
+
+TESTS = run-bindtests \
+       t/guestfs_005_load t/guestfs_010_launch t/guestfs_050_lvcreate
+noinst_DATA += bindtests \
+       t/guestfs_005_load t/guestfs_010_launch t/guestfs_050_lvcreate
+
+bindtests: bindtests.ml mlguestfs.cmxa
+       $(OCAMLFIND) ocamlopt -cclib -L$(top_builddir)/src/.libs -I . unix.cmxa mlguestfs.cmxa $< -o $@
+
+t/guestfs_005_load: t/guestfs_005_load.ml mlguestfs.cmxa
+       $(OCAMLFIND) ocamlopt -cclib -L$(top_builddir)/src/.libs -I . unix.cmxa mlguestfs.cmxa $< -o $@
+
+t/guestfs_010_launch: t/guestfs_010_launch.ml mlguestfs.cmxa
+       $(OCAMLFIND) ocamlopt -cclib -L$(top_builddir)/src/.libs -I . unix.cmxa mlguestfs.cmxa $< -o $@
+
+t/guestfs_050_lvcreate: t/guestfs_050_lvcreate.ml mlguestfs.cmxa
+       $(OCAMLFIND) ocamlopt -cclib -L$(top_builddir)/src/.libs -I . unix.cmxa mlguestfs.cmxa $< -o $@
+
 .mli.cmi:
        $(OCAMLFIND) ocamlc -c $<
 .ml.cmo:
@@ -66,4 +92,10 @@ install-data-hook:
          guestfs \
          META *.so *.a *.cma *.cmx *.cmxa *.cmi *.mli
 
-endif
\ No newline at end of file
+CLEANFILES += $(noinst_DATA)
+
+endif
+
+# Tell version 3.79 and up of GNU make to not build goals in this
+# directory in parallel.  (Possible solution for RHBZ#502309).
+.NOTPARALLEL: