build: add -I option to get config.h.
[libguestfs.git] / ocaml / Makefile.am
index bf9760c..1aa0cb6 100644 (file)
@@ -28,6 +28,9 @@ SUBDIRS = examples
 CLEANFILES = *.cmi *.cmo *.cmx *.cma *.cmxa *.o *.a *.so
 CLEANFILES += t/*.cmi t/*.cmo t/*.cmx t/*.o t/*.a t/*.so
 
+AM_CPPFLAGS = -I$(top_builddir) -I$(OCAMLLIB) -I$(top_srcdir)/ocaml \
+  -I$(top_srcdir)/src -I$(top_builddir)/src
+
 if HAVE_OCAML
 
 noinst_DATA = mlguestfs.cma mlguestfs.cmxa META
@@ -39,10 +42,10 @@ mlguestfs.cmxa: guestfs_c.o guestfs_c_actions.o guestfs.cmx
        $(OCAMLMKLIB) -o mlguestfs $^ -L$(top_builddir)/src/.libs -lguestfs
 
 guestfs_c.o: guestfs_c.c
-       $(CC) $(CFLAGS) -I$(OCAMLLIB) -I$(top_srcdir)/ocaml -I$(top_srcdir)/src -I$(top_builddir)/src -fPIC -Wall -c $<
+       $(CC) $(AM_CPPFLAGS) $(CFLAGS) -fPIC -Wall -c $<
 
 guestfs_c_actions.o: guestfs_c_actions.c
-       $(CC) $(CFLAGS) -I$(OCAMLLIB) -I$(top_srcdir)/ocaml -I$(top_srcdir)/src -I$(top_builddir)/src -fPIC -Wall -c $<
+       $(CC) $(AM_CPPFLAGS) $(CFLAGS) -fPIC -Wall -c $<
 
 TESTS_ENVIRONMENT = \
        LD_LIBRARY_PATH=$(top_builddir)/src/.libs \
@@ -56,31 +59,37 @@ noinst_DATA += bindtests \
        t/guestfs_005_load t/guestfs_010_launch t/guestfs_050_lvcreate \
        t/guestfs_060_readdir
 
-bindtests: bindtests.ml mlguestfs.cmxa
+bindtests: bindtests.cmx mlguestfs.cmxa
+       mkdir -p t
        $(OCAMLFIND) ocamlopt -cclib -L$(top_builddir)/src/.libs -I . unix.cmxa mlguestfs.cmxa $< -o $@
 
-t/guestfs_005_load: t/guestfs_005_load.ml mlguestfs.cmxa
+t/guestfs_005_load: t/guestfs_005_load.cmx mlguestfs.cmxa
        mkdir -p t
        $(OCAMLFIND) ocamlopt -cclib -L$(top_builddir)/src/.libs -I . unix.cmxa mlguestfs.cmxa $< -o $@
 
-t/guestfs_010_launch: t/guestfs_010_launch.ml mlguestfs.cmxa
+t/guestfs_010_launch: t/guestfs_010_launch.cmx mlguestfs.cmxa
        mkdir -p t
        $(OCAMLFIND) ocamlopt -cclib -L$(top_builddir)/src/.libs -I . unix.cmxa mlguestfs.cmxa $< -o $@
 
-t/guestfs_050_lvcreate: t/guestfs_050_lvcreate.ml mlguestfs.cmxa
+t/guestfs_050_lvcreate: t/guestfs_050_lvcreate.cmx mlguestfs.cmxa
        mkdir -p t
        $(OCAMLFIND) ocamlopt -cclib -L$(top_builddir)/src/.libs -I . unix.cmxa mlguestfs.cmxa $< -o $@
 
-t/guestfs_060_readdir: t/guestfs_060_readdir.ml mlguestfs.cmxa
+t/guestfs_060_readdir: t/guestfs_060_readdir.cmx mlguestfs.cmxa
        mkdir -p t
        $(OCAMLFIND) ocamlopt -cclib -L$(top_builddir)/src/.libs -I . unix.cmxa mlguestfs.cmxa $< -o $@
 
+# Need to rebuild the tests from source if the main library has
+# changed at all, otherwise we get inconsistent assumptions.
+t/%.cmx: t/%.ml mlguestfs.cmxa
+       $(OCAMLFIND) ocamlopt -c $< -o $@
+
 .mli.cmi:
-       $(OCAMLFIND) ocamlc -c $<
+       $(OCAMLFIND) ocamlc -c $< -o $@
 .ml.cmo:
-       $(OCAMLFIND) ocamlc -c $<
+       $(OCAMLFIND) ocamlc -c $< -o $@
 .ml.cmx:
-       $(OCAMLFIND) ocamlopt -c $<
+       $(OCAMLFIND) ocamlopt -c $< -o $@
 
 depend: .depend