java: Add guestfs-java(3) man page.
[libguestfs.git] / java / examples / Makefile.am
diff --git a/java/examples/Makefile.am b/java/examples/Makefile.am
new file mode 100644 (file)
index 0000000..503b55d
--- /dev/null
@@ -0,0 +1,50 @@
+# libguestfs Java examples
+# Copyright (C) 2011 Red Hat Inc.
+#
+# This program is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
+
+EXTRA_DIST = \
+       LICENSE \
+       CreateDisk.java \
+       InspectVM.java \
+       guestfs-java.pod
+
+CLEANFILES = \
+       *.class \
+       stamp-guestfs-java.pod
+
+man_MANS = guestfs-java.3
+noinst_DATA = $(top_builddir)/html/guestfs-java.3.html
+
+guestfs-java.3 $(top_builddir)/html/guestfs-java.3.html: stamp-guestfs-java.pod
+
+stamp-guestfs-java.pod: guestfs-java.pod CreateDisk.java InspectVM.java
+       $(top_srcdir)/podwrapper.sh \
+         --section 3 \
+         --man guestfs-java.3 \
+         --html $(top_builddir)/html/guestfs-java.3.html \
+         --verbatim CreateDisk.java:@EXAMPLE1@ \
+         --verbatim InspectVM.java:@EXAMPLE2@ \
+         $<
+       touch $@
+
+if HAVE_JAVA
+
+noinst_SCRIPTS = CreateDisk.class InspectVM.class
+
+%.class: %.java
+       $(JAVAC) $(JAVAC_FLAGS) -classpath ../libguestfs-$(VERSION).jar $<
+
+endif