Move the appliance and build scripts into new appliance/ subdirectory.
[libguestfs.git] / java / Makefile.am
index ea4de6a..cc9891b 100644 (file)
@@ -37,7 +37,7 @@ EXTRA_DIST = \
        $(java_tests) \
        run-java-test
 
-CLEANFILES = *~ doc-stamp
+CLEANFILES = doc-stamp
 
 if HAVE_JAVA
 
@@ -90,10 +90,14 @@ TESTS = $(java_tests:.java=.class)
 TESTS_ENVIRONMENT = \
        JAVA=$(JAVA) \
        CLASSPATH=t:libguestfs-$(VERSION).jar \
-       LIBGUESTFS_PATH=$(abs_top_builddir) \
+       LIBGUESTFS_PATH=$(top_builddir)/appliance \
        ./run-java-test
 
 t/%.class: t/%.java
        $(JAVAC) $(JAVAC_FLAGS) -classpath libguestfs-$(VERSION).jar $<
 
-endif
\ No newline at end of file
+endif
+
+# Tell version 3.79 and up of GNU make to not build goals in this
+# directory in parallel.
+.NOTPARALLEL: