generator: Missing newline character.
[libguestfs.git] / inspector / Makefile.am
index 25f5e3c..e1fe44a 100644 (file)
 # along with this program; if not, write to the Free Software
 # Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
 
+include $(top_srcdir)/subdir-rules.mk
+
 EXTRA_DIST = \
        run-inspector-locally \
-       virt-inspector \
+       virt-inspector
+
+docdir = @docdir@
+dist_doc_DATA = \
        virt-inspector.rng \
        example1.xml example2.xml example3.xml example4.xml
 
@@ -25,11 +30,9 @@ if HAVE_INSPECTOR
 
 bin_SCRIPTS = virt-inspector
 man_MANS = virt-inspector.1
-dist_doc_DATA = \
-       virt-inspector.rng \
-       example1.xml example2.xml example3.xml example4.xml
 
-noinst_DATA = $(top_builddir)/html/virt-inspector.1.html
+noinst_DATA = \
+       $(top_builddir)/html/virt-inspector.1.html
 
 virt-inspector.1: virt-inspector
        $(POD2MAN) \
@@ -55,3 +58,12 @@ TESTS_ENVIRONMENT = $(XMLLINT) --noout --relaxng virt-inspector.rng
 endif
 
 endif
+
+# Make symlink from virt-inspector.pl to virt-inspector.  This is just
+# to keep xgettext happy since it uses the file extension to determine
+# the implementation language of a file.
+
+all-local: virt-inspector.pl
+
+virt-inspector.pl: virt-inspector
+       ln -sf $< $@