Use a squashfs attached as /dev/sdd during the C API tests.
[libguestfs.git] / inspector / Makefile.am
index 528e183..b43870d 100644 (file)
 # Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
 
 EXTRA_DIST = \
+       run-inspector-locally \
        virt-inspector.pl
 
-CLEANFILES = *~
-
 if HAVE_INSPECTOR
 
 man_MANS = virt-inspector.1
 
+noinst_DATA = ../html/virt-inspector.1.html
+
 virt-inspector.1: virt-inspector.pl
        $(POD2MAN) \
          --section 1 \
@@ -31,8 +32,16 @@ virt-inspector.1: virt-inspector.pl
          --release "$(PACKAGE_NAME)-$(PACKAGE_VERSION)" \
          $< > $@
 
+../html/virt-inspector.1.html: virt-inspector.pl
+       cd .. && pod2html \
+         --css 'pod.css' \
+         --title 'virt-inspector, display OS version, kernel, drivers, mount points, applications, etc. in a virtual machine' \
+         --htmldir html \
+         --outfile html/virt-inspector.1.html \
+         inspector/$<
+
 install-data-hook:
        mkdir -p $(DESTDIR)$(bindir)
        install -m 0755 virt-inspector.pl $(DESTDIR)$(bindir)/virt-inspector
 
-endif
\ No newline at end of file
+endif