daemon: debug segv correct use of dereferencing NULL.
[libguestfs.git] / inspector / Makefile.am
index 435ba87..8ef8734 100644 (file)
@@ -13,7 +13,7 @@
 #
 # You should have received a copy of the GNU General Public License
 # along with this program; if not, write to the Free Software
-# Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
+# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
 
 include $(top_srcdir)/subdir-rules.mk
 
@@ -33,7 +33,6 @@ EXAMPLE_XML = \
        example-windows-xp-cd.xml
 
 EXTRA_DIST = \
-       run-inspector-locally \
        virt-inspector.pod
 
 CLEANFILES = stamp-virt-inspector.pod
@@ -60,6 +59,7 @@ virt_inspector_SOURCES = \
        virt-inspector.c
 
 virt_inspector_CFLAGS = \
+       -DGUESTFS_WARN_DEPRECATED=1 \
        -I$(top_srcdir)/src -I$(top_builddir)/src \
        -I$(top_srcdir)/fish \
        -I$(srcdir)/../gnulib/lib -I../gnulib/lib \
@@ -81,7 +81,7 @@ noinst_DATA = $(top_builddir)/html/virt-inspector.1.html
 virt-inspector.1 $(top_builddir)/html/virt-inspector.1.html: stamp-virt-inspector.pod
 
 stamp-virt-inspector.pod: virt-inspector.pod
-       $(top_srcdir)/podwrapper.sh \
+       $(top_builddir)/podwrapper.sh \
          --man virt-inspector.1 \
          --html $(top_builddir)/html/virt-inspector.1.html \
          $<
@@ -90,7 +90,7 @@ stamp-virt-inspector.pod: virt-inspector.pod
 if HAVE_XMLLINT
 
 TESTS = $(EXAMPLE_XML)
-TESTS_ENVIRONMENT = $(XMLLINT) --noout --relaxng virt-inspector.rng
+TESTS_ENVIRONMENT = $(XMLLINT) --noout --relaxng $(srcdir)/virt-inspector.rng
 
 endif
 
@@ -101,17 +101,18 @@ endif
 
 example-debian.xml:
        rm -f $@ $@-t
-       ./run-inspector-locally ../images/debian.img > $@-t
+       ../run $(builddir)/virt-inspector ../tests/guests/debian.img > $@-t
        mv $@-t $@
 example-fedora.xml:
        rm -f $@ $@-t
-       ./run-inspector-locally ../images/fedora.img > $@-t
+       ../run $(builddir)/virt-inspector ../tests/guests/fedora.img > $@-t
        mv $@-t $@
 example-ubuntu.xml:
        rm -f $@ $@-t
-       ./run-inspector-locally ../images/ubuntu.img > $@-t
+       ../run $(builddir)/virt-inspector ../tests/guests/ubuntu.img > $@-t
        mv $@-t $@
 example-windows.xml:
        rm -f $@ $@-t
-       ./run-inspector-locally ../images/windows.img | fgrep -v '<uuid>' > $@-t
+       ../run $(builddir)/virt-inspector ../tests/guests/windows.img | \
+           fgrep -v '<uuid>' > $@-t
        mv $@-t $@