inspector: Add tests for RELAX NG schema.
[libguestfs.git] / inspector / Makefile.am
index 7dd71dc..25f5e3c 100644 (file)
 # Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
 
 EXTRA_DIST = \
-       run-inspector-locally
+       run-inspector-locally \
+       virt-inspector \
+       virt-inspector.rng \
+       example1.xml example2.xml example3.xml example4.xml
 
 if HAVE_INSPECTOR
 
 bin_SCRIPTS = virt-inspector
 man_MANS = virt-inspector.1
+dist_doc_DATA = \
+       virt-inspector.rng \
+       example1.xml example2.xml example3.xml example4.xml
 
 noinst_DATA = $(top_builddir)/html/virt-inspector.1.html
 
@@ -41,4 +47,11 @@ $(top_builddir)/html/virt-inspector.1.html: virt-inspector
          --outfile html/virt-inspector.1.html \
          inspector/$<
 
+if HAVE_XMLLINT
+
+TESTS = example1.xml example2.xml example3.xml example4.xml
+TESTS_ENVIRONMENT = $(XMLLINT) --noout --relaxng virt-inspector.rng
+
+endif
+
 endif