images: Make phony Ubuntu image for testing.
[libguestfs.git] / images / Makefile.am
index 3c30df5..d97dd45 100644 (file)
@@ -1,5 +1,5 @@
 # libguestfs test images
-# Copyright (C) 2009 Red Hat Inc.
+# Copyright (C) 2009-2010 Red Hat Inc.
 #
 # This program is free software; you can redistribute it and/or modify
 # it under the terms of the GNU General Public License as published by
 # along with this program; if not, write to the Free Software
 # Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
 
+include $(top_srcdir)/subdir-rules.mk
+
 # Old RHEL 5 autoconf doesn't have builddir.
 builddir ?= $(top_builddir)/images
 
 EXTRA_DIST = \
        helloworld.tar \
        helloworld.tar.gz \
+       helloworld.tar.xz \
        mbr-ext2-empty.img.gz \
        empty known-1 known-2 known-3 known-4 known-5 \
        bin-i586-dynamic \
@@ -33,18 +36,29 @@ EXTRA_DIST = \
        lib-win32.dll \
        lib-win64.dll \
        lib-x86_64.so \
-       test-grep.txt
+       test-grep.txt \
+       guest-aux/make-debian-img.sh \
+       guest-aux/debian-packages \
+       guest-aux/make-fedora-img.sh \
+       guest-aux/fedora-name.db.txt \
+       guest-aux/fedora-name.db \
+       guest-aux/make-ubuntu-img.sh
+
+noinst_DATA = test.iso
 
-noinst_DATA = test.sqsh
+# This is 'check_DATA' because we don't need it until 'make check'
+# time and we need the tools we have built in order to make it.
+check_DATA = debian.img fedora.img ubuntu.img
 
 CLEANFILES = \
-       test.sqsh \
+       test.iso test.sqsh \
        100kallzeroes 100kallnewlines 100kallspaces 100krandom 10klines \
-       initrd
+       initrd $(check_DATA)
 
-squash_files_src = \
+images_files_src = \
        $(srcdir)/helloworld.tar \
        $(srcdir)/helloworld.tar.gz \
+       $(srcdir)/helloworld.tar.xz \
        $(srcdir)/empty \
        $(srcdir)/known-1 \
        $(srcdir)/known-2 \
@@ -63,23 +77,27 @@ squash_files_src = \
        $(srcdir)/lib-x86_64.so \
        $(srcdir)/test-grep.txt
 
-squash_files_build = \
+images_files_build = \
        $(builddir)/100kallzeroes \
        $(builddir)/100kallnewlines \
        $(builddir)/100kallspaces \
        $(builddir)/100krandom \
        $(builddir)/10klines \
+       $(builddir)/abssymlink \
+       $(builddir)/hello.b64 \
        $(builddir)/initrd \
        $(builddir)/initrd-x86_64.img \
        $(builddir)/initrd-x86_64.img.gz \
        $(builddir)/test-grep.txt.gz
 
-squash_files = $(squash_files_src) $(squash_files_build)
+images_files = $(images_files_src) $(images_files_build)
 
-test.sqsh: $(squash_files)
+test.iso: $(images_files)
        rm -f $@ $@-t
        mkdir -p directory
-       $(MKSQUASHFS) $(squash_files) directory $@-t
+       $(MKISOFS) -J -r -graft-points \
+         -o $@-t \
+         $(images_files) /directory=directory
        rmdir directory
        mv $@-t $@
 
@@ -112,6 +130,12 @@ $(builddir)/10klines:
        done > $@-t
        mv $@-t $@
 
+$(builddir)/abssymlink:
+       ln -sf /10klines $@
+
+$(builddir)/hello.b64:
+       echo "hello" | base64 > $@
+
 $(builddir)/initrd: empty known-1 known-2 known-3 known-4 known-5
        rm -f $@ $@-t
        for f in $^; do echo $$f; done | cpio -o -H newc | gzip --best > $@-t
@@ -136,3 +160,24 @@ $(builddir)/test-grep.txt.gz: test-grep.txt
        rm -f $@ $@-t
        gzip --best -c $< > $@-t
        mv $@-t $@
+
+# Make a (dummy) Fedora image.
+fedora.img: guest-aux/make-fedora-img.sh guest-aux/fedora-name.db
+       LIBGUESTFS_PATH=../appliance \
+       LD_LIBRARY_PATH=../src/.libs \
+       bash $<
+
+guest-aux/fedora-name.db: guest-aux/fedora-name.db.txt
+       db_load $@ < $<
+
+# Make a (dummy) Debian image.
+debian.img: guest-aux/make-debian-img.sh
+       LIBGUESTFS_PATH=../appliance \
+       LD_LIBRARY_PATH=../src/.libs \
+       bash $<
+
+# Make a (dummy) Ubuntu image.
+ubuntu.img: guest-aux/make-ubuntu-img.sh
+       LIBGUESTFS_PATH=../appliance \
+       LD_LIBRARY_PATH=../src/.libs \
+       bash $<