Delete file so db_load doesn't run incrementally.
[libguestfs.git] / images / Makefile.am
index 97fccce..4b253a3 100644 (file)
@@ -176,10 +176,14 @@ fedora.img: guest-aux/make-fedora-img.sh \
        bash $<
 
 guest-aux/fedora-name.db: guest-aux/fedora-name.db.txt
-       $(DB_LOAD) $@ < $<
+       rm -f $@ $@-t
+       $(DB_LOAD) $@-t < $<
+       mv $@-t $@
 
 guest-aux/fedora-packages.db: guest-aux/fedora-packages.db.txt
-       $(DB_LOAD) $@ < $<
+       rm -f $@ $@-t
+       $(DB_LOAD) $@-t < $<
+       mv $@-t $@
 
 # Make a (dummy) Debian image.
 debian.img: guest-aux/make-debian-img.sh