tests: Rename capitests -> tests/c-api.
[libguestfs.git] / generator / Makefile.am
index cb0a987..dfa5893 100644 (file)
@@ -1,5 +1,5 @@
 # libguestfs
-# Copyright (C) 2010 Red Hat Inc.
+# Copyright (C) 2010-2011 Red Hat Inc.
 #
 # This program is free software; you can redistribute it and/or modify
 # it under the terms of the GNU General Public License as published by
@@ -13,7 +13,7 @@
 #
 # You should have received a copy of the GNU General Public License
 # along with this program; if not, write to the Free Software
-# Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
+# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
 
 SOURCES = \
        generator_types.ml \
@@ -28,6 +28,7 @@ SOURCES = \
        generator_optgroups.ml \
        generator_prepopts.mli \
        generator_prepopts.ml \
+       generator_events.ml \
        generator_pr.mli \
        generator_pr.ml \
        generator_docstrings.ml \
@@ -35,7 +36,7 @@ SOURCES = \
        generator_c.ml \
        generator_xdr.ml \
        generator_daemon.ml \
-       generator_capitests.ml \
+       generator_tests_c_api.ml \
        generator_fish.ml \
        generator_ocaml.ml \
        generator_perl.ml \
@@ -45,6 +46,7 @@ SOURCES = \
        generator_haskell.ml \
        generator_csharp.ml \
        generator_php.ml \
+       generator_erlang.ml \
        generator_bindtests.ml \
        generator_errnostring.ml \
        generator_main.ml
@@ -52,23 +54,23 @@ SOURCES = \
 SOURCES_ML = $(filter %.ml,$(SOURCES))
 OBJECTS = $(SOURCES_ML:.ml=.cmo)
 
-EXTRA_DIST = $(SOURCES)
+EXTRA_DIST = $(SOURCES) files-generated.txt
 
-OCAMLCFLAGS = -I +xml-light -I +../pkg-lib/xml-light -warn-error CDEFLMPSUVYZX
-OCAMLCLIBS = xml-light.cma unix.cma str.cma
+OCAMLCFLAGS = -warn-error CDEFLMPSUVYZX
+OCAMLCLIBS = unix.cma str.cma
 
 noinst_PROGRAM = generator
 
 if HAVE_OCAML
 
-generator: $(OBJECTS)
-       $(OCAMLC) -o generator $(OCAMLCFLAGS) $(OCAMLCLIBS) $(OBJECTS)
+$(srcdir)/generator: $(OBJECTS)
+       $(OCAMLC) -I $(srcdir) -o $@ $(OCAMLCFLAGS) $(OCAMLCLIBS) $(OBJECTS)
 
 .ml.cmo:
-       $(OCAMLC) $(OCAMLCFLAGS) -c $< -o $@
+       $(OCAMLC) -I $(srcdir) $(OCAMLCFLAGS) -c $< -o $@
 
 .mli.cmi:
-       $(OCAMLC) $(OCAMLCFLAGS) -c $< -o $@
+       $(OCAMLC) -I $(srcdir) $(OCAMLCFLAGS) -c $< -o $@
 
 depend: .depend
 
@@ -84,7 +86,7 @@ else
 # No OCaml compiler.  Just replace the generator with a script that
 # touches stamp-generator and prints a warning.
 
-generator: $(SOURCES)
+$(srcdir)/generator: $(SOURCES)
        rm -f $@ $@-t
        echo 'echo Warning: Install OCaml compiler in order to rebuild the generated files.' >> $@-t
        echo 'touch generator/stamp-generator' >> $@-t