tests: Rename capitests -> tests/c-api.
[libguestfs.git] / generator / Makefile.am
index a127a87..dfa5893 100644 (file)
@@ -1,5 +1,5 @@
 # libguestfs
-# Copyright (C) 2010 Red Hat Inc.
+# Copyright (C) 2010-2011 Red Hat Inc.
 #
 # This program is free software; you can redistribute it and/or modify
 # it under the terms of the GNU General Public License as published by
@@ -13,7 +13,7 @@
 #
 # You should have received a copy of the GNU General Public License
 # along with this program; if not, write to the Free Software
-# Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
+# Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
 
 SOURCES = \
        generator_types.ml \
@@ -36,7 +36,7 @@ SOURCES = \
        generator_c.ml \
        generator_xdr.ml \
        generator_daemon.ml \
-       generator_capitests.ml \
+       generator_tests_c_api.ml \
        generator_fish.ml \
        generator_ocaml.ml \
        generator_perl.ml \
@@ -46,6 +46,7 @@ SOURCES = \
        generator_haskell.ml \
        generator_csharp.ml \
        generator_php.ml \
+       generator_erlang.ml \
        generator_bindtests.ml \
        generator_errnostring.ml \
        generator_main.ml
@@ -85,7 +86,7 @@ else
 # No OCaml compiler.  Just replace the generator with a script that
 # touches stamp-generator and prints a warning.
 
-generator: $(SOURCES)
+$(srcdir)/generator: $(SOURCES)
        rm -f $@ $@-t
        echo 'echo Warning: Install OCaml compiler in order to rebuild the generated files.' >> $@-t
        echo 'touch generator/stamp-generator' >> $@-t