Version 1.5.23.
[libguestfs.git] / fuse / Makefile.am
index ebf948a..db0e418 100644 (file)
@@ -15,7 +15,9 @@
 # along with this program; if not, write to the Free Software
 # Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
 
 # along with this program; if not, write to the Free Software
 # Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
 
-EXTRA_DIST = guestmount.pod
+include $(top_srcdir)/subdir-rules.mk
+
+EXTRA_DIST = guestmount.pod test-fuse.sh
 
 if HAVE_FUSE
 
 
 if HAVE_FUSE
 
@@ -31,6 +33,7 @@ guestmount_CFLAGS = \
        -I$(top_srcdir)/src -I$(top_builddir)/src \
        -I$(srcdir)/../gnulib/lib -I../gnulib/lib \
        -DGUESTFS_DEFAULT_PATH='"$(libdir)/guestfs"' \
        -I$(top_srcdir)/src -I$(top_builddir)/src \
        -I$(srcdir)/../gnulib/lib -I../gnulib/lib \
        -DGUESTFS_DEFAULT_PATH='"$(libdir)/guestfs"' \
+       -DLOCALEBASEDIR=\""$(datadir)/locale"\" \
        $(FUSE_CFLAGS) \
        $(WARN_CFLAGS) $(WERROR_CFLAGS)
 
        $(FUSE_CFLAGS) \
        $(WARN_CFLAGS) $(WERROR_CFLAGS)
 
@@ -39,6 +42,12 @@ guestmount_LDADD = \
        $(top_builddir)/src/libguestfs.la \
        ../gnulib/lib/libgnu.la
 
        $(top_builddir)/src/libguestfs.la \
        ../gnulib/lib/libgnu.la
 
+# Build a partly-static library (for the binary distribution).
+
+guestmount.static$(EXEEXT): $(guestmount_OBJECTS) $(guestmount_DEPENDENCIES)
+       $(top_srcdir)/relink-static.sh \
+       $(guestmount_LINK) $(guestmount_OBJECTS) -static $(guestmount_LDADD) $(guestmount_LIBS) -lpcre -lhivex -lmagic -lz
+
 # Documentation.
 
 man_MANS = guestmount.1
 # Documentation.
 
 man_MANS = guestmount.1