fish: Add guestfish -N lv for creating disks with LVs.
[libguestfs.git] / fish / Makefile.am
index f6b3e7d..d5c1dab 100644 (file)
@@ -22,7 +22,9 @@ bin_PROGRAMS = guestfish
 generator_built = \
        cmds.c \
        completion.c \
-       guestfish-actions.pod
+       guestfish-actions.pod \
+       prepopts.h \
+       prepopts.c
 
 BUILT_SOURCES = \
        $(generator_built) \
@@ -44,15 +46,23 @@ guestfish_SOURCES = \
        fish.c \
        fish.h \
        glob.c \
+       inspect.c \
        lcd.c \
        man.c \
        more.c \
        prep.c \
+       prep_disk.c \
+       prep_part.c \
+       prep_fs.c \
+       prep_lv.c \
+       progress.c \
        rc.c \
        reopen.c \
+       rmsd.h \
        supported.c \
        tilde.c \
-       time.c
+       time.c \
+       virt.c
 
 # This convenience library is solely to avoid compiler warnings
 # in its generated sources.
@@ -65,9 +75,12 @@ guestfish_CFLAGS = \
        -DGUESTFS_DEFAULT_PATH='"$(libdir)/guestfs"' \
        -DLOCALEBASEDIR=\""$(datadir)/locale"\" \
        -I$(srcdir)/../gnulib/lib -I../gnulib/lib \
+       $(LIBVIRT_CFLAGS) $(LIBXML2_CFLAGS) \
        $(WARN_CFLAGS) $(WERROR_CFLAGS)
 
-guestfish_LDADD = $(top_builddir)/src/libguestfs.la $(LIBREADLINE)
+guestfish_LDADD = \
+       $(LIBVIRT_LIBS) $(LIBXML2_LIBS) \
+       $(top_builddir)/src/libguestfs.la $(LIBREADLINE) -lm
 
 # Make libguestfs use the convenience library.
 noinst_LTLIBRARIES = librc_protocol.la
@@ -87,6 +100,12 @@ rc_protocol.h: rc_protocol.x
        mv $@-t $@
 endif
 
+# Build a partly-static library (for the binary distribution).
+
+guestfish.static$(EXEEXT): $(guestfish_OBJECTS) $(guestfish_DEPENDENCIES)
+       $(top_srcdir)/relink-static.sh \
+       $(guestfish_LINK) $(guestfish_OBJECTS) -static $(guestfish_LDADD) $(guestfish_LIBS) -ltinfo -lpcre -lhivex -lmagic -lz -lm
+
 # Manual page.
 # guestfish-actions.pod is autogenerated.  There is no include
 # mechanism for POD, so we have to do it by hand.