convert uses of strcasecmp to STRCASEEQ
[libguestfs.git] / fish / Makefile.am
index 5bf3fbd..c8ba3ea 100644 (file)
@@ -51,14 +51,15 @@ BUILT_SOURCES = \
 guestfish_CFLAGS = \
        -I$(top_srcdir)/src -I$(top_builddir)/src \
        -I$(top_srcdir)/fish -I$(top_builddir)/fish \
-       -Wall \
-       -DGUESTFS_DEFAULT_PATH='"$(libdir)/guestfs"'
+       -DGUESTFS_DEFAULT_PATH='"$(libdir)/guestfs"' \
+       -I$(srcdir)/../gnulib/lib -I../gnulib/lib \
+       $(WARN_CFLAGS) $(WERROR_CFLAGS)
 
 guestfish_LDADD = $(top_builddir)/src/libguestfs.la $(LIBREADLINE)
 
 # Make libguestfs use the convenience library.
 noinst_LTLIBRARIES = librc_protocol.la
-guestfish_LDADD += librc_protocol.la
+guestfish_LDADD += librc_protocol.la ../gnulib/lib/libgnu.la
 
 if HAVE_RPCGEN
 rc_protocol.c: rc_protocol.x