fish: First pass at guestfish bash completion script.
[libguestfs.git] / fish / Makefile.am
index b3782ec..bdb1acb 100644 (file)
@@ -1,5 +1,5 @@
 # libguestfs
-# Copyright (C) 2009 Red Hat Inc.
+# Copyright (C) 2009-2010 Red Hat Inc.
 #
 # This program is free software; you can redistribute it and/or modify
 # it under the terms of the GNU General Public License as published by
 # along with this program; if not, write to the Free Software
 # Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
 
+include $(top_srcdir)/subdir-rules.mk
+
 bin_PROGRAMS = guestfish
 
-guestfish_SOURCES = \
-       alloc.c \
+generator_built = \
        cmds.c \
        completion.c \
+       guestfish-actions.pod
+
+BUILT_SOURCES = \
+       $(generator_built) \
+       rc_protocol.h \
+       rc_protocol.c
+
+EXTRA_DIST = \
+       $(BUILT_SOURCES) \
+       rc_protocol.x \
+       guestfish.pod
+
+guestfish_SOURCES = \
+       $(generator_built) \
+       alloc.c \
+       destpaths.c \
        echo.c \
        edit.c \
        fish.c \
-       fish.h
+       fish.h \
+       glob.c \
+       lcd.c \
+       man.c \
+       more.c \
+       prep.c \
+       rc.c \
+       reopen.c \
+       supported.c \
+       tilde.c \
+       time.c
+
+# This convenience library is solely to avoid compiler warnings
+# in its generated sources.
+librc_protocol_la_SOURCES = rc_protocol.c
+librc_protocol_la_CFLAGS = -Wall -Wno-unused
+
 guestfish_CFLAGS = \
-       -I$(top_builddir)/src -Wall \
-       -DGUESTFS_DEFAULT_PATH='"$(libdir)/guestfs"'
+       -I$(top_srcdir)/src -I$(top_builddir)/src \
+       -I$(top_srcdir)/fish -I$(top_builddir)/fish \
+       -DGUESTFS_DEFAULT_PATH='"$(libdir)/guestfs"' \
+       -DLOCALEBASEDIR=\""$(datadir)/locale"\" \
+       -I$(srcdir)/../gnulib/lib -I../gnulib/lib \
+       $(WARN_CFLAGS) $(WERROR_CFLAGS)
+
 guestfish_LDADD = $(top_builddir)/src/libguestfs.la $(LIBREADLINE)
+
+# Make libguestfs use the convenience library.
+noinst_LTLIBRARIES = librc_protocol.la
+guestfish_LDADD += librc_protocol.la ../gnulib/lib/libgnu.la
+
+if HAVE_RPCGEN
+rc_protocol.c: rc_protocol.x
+       rm -f $@-t $@-t2
+       $(RPCGEN) -c -o $@-t $<
+       sed 's,\.\./\.\./fish/,,' < $@-t > $@-t2
+       rm $@-t
+       mv $@-t2 $@
+
+rc_protocol.h: rc_protocol.x
+       rm -f $@-t
+       $(RPCGEN) -h -o $@-t $<
+       mv $@-t $@
+endif
+
+# Manual page.
+# guestfish-actions.pod is autogenerated.  There is no include
+# mechanism for POD, so we have to do it by hand.
+
+man_MANS = guestfish.1
+
+guestfish.1: guestfish.pod guestfish-actions.pod
+       sed \
+         -e '/@ACTIONS@/rguestfish-actions.pod' -e 's/@ACTIONS@//' \
+         < $< | \
+       $(POD2MAN) \
+         --section 1 \
+         -c "Virtualization Support" \
+         --name "guestfish" \
+         --release "$(PACKAGE_NAME)-$(PACKAGE_VERSION)" \
+         > $@
+
+# Bash completion script.
+
+bashcompletiondir = $(sysconfdir)/bash_completion.d
+bashcompletion_DATA = guestfish-bash-completion.sh