fish: Add 'display' command for displaying graphical files.
[libguestfs.git] / fish / Makefile.am
index 311da89..9e05170 100644 (file)
@@ -1,5 +1,5 @@
 # libguestfs
-# Copyright (C) 2009-2010 Red Hat Inc.
+# Copyright (C) 2009-2011 Red Hat Inc.
 #
 # This program is free software; you can redistribute it and/or modify
 # it under the terms of the GNU General Public License as published by
@@ -46,6 +46,7 @@ EXTRA_DIST = \
        rc_protocol.x \
        guestfish.pod \
        guestfish-bash-completion.sh \
+       libguestfs-tools.conf \
        virt-copy-in \
        virt-copy-out \
        virt-tar-in \
@@ -60,6 +61,7 @@ EXTRA_DIST = \
 # so we know which ones are shared.  These files must not include
 # other guestfish files.
 SHARED_SOURCE_FILES = \
+       config.c \
        inspect.c \
        keys.c \
        options.h \
@@ -73,6 +75,7 @@ guestfish_SOURCES = \
        cmds_gperf.h \
        copy.c \
        destpaths.c \
+       display.c \
        echo.c \
        edit.c \
        fish.c \
@@ -97,10 +100,10 @@ guestfish_SOURCES = \
        tilde.c \
        time.c
 
-# This convenience library is solely to avoid compiler warnings
-# in its generated sources.
-librc_protocol_la_SOURCES = rc_protocol.c
-librc_protocol_la_CFLAGS = -Wall -Wno-unused
+# This convenience library is solely to compile its generated sources with
+# custom flags.
+librc_protocol_la_SOURCES = rc_protocol.c rc_protocol.h
+librc_protocol_la_CFLAGS = -Wall -Wno-unused -fno-strict-aliasing
 
 # Build the command lookup perfect hash code.  The generated code has
 # lots of warnings so we must compile it in a separate mini-library.
@@ -113,15 +116,18 @@ cmds_gperf.c: cmds_gperf.gperf
        mv $@-t $@
 
 guestfish_CFLAGS = \
+       -DGUESTFS_WARN_DEPRECATED=1 \
        -I$(top_srcdir)/src -I$(top_builddir)/src \
        -I$(top_srcdir)/fish -I$(top_builddir)/fish \
-       -DGUESTFS_DEFAULT_PATH='"$(libdir)/guestfs"' \
        -DLOCALEBASEDIR=\""$(datadir)/locale"\" \
        -I$(srcdir)/../gnulib/lib -I../gnulib/lib \
-       $(WARN_CFLAGS) $(WERROR_CFLAGS)
+       $(WARN_CFLAGS) $(WERROR_CFLAGS) \
+       $(LIBCONFIG_CFLAGS)
 
 guestfish_LDADD = \
-       $(top_builddir)/src/libguestfs.la $(LIBREADLINE) -lm
+       $(LIBCONFIG_LIBS) \
+       $(LIBREADLINE) \
+       $(top_builddir)/src/libguestfs.la -lm
 
 # Make guestfish use the convenience libraries.
 noinst_LTLIBRARIES = libcmds.la librc_protocol.la
@@ -207,6 +213,11 @@ stamp-virt-tar-out.pod: virt-tar-out.pod
          $<
        touch $@
 
+# libguestfs tools config file.
+
+toolsconfdir = $(sysconfdir)
+toolsconf_DATA = libguestfs-tools.conf
+
 # Bash completion script.
 
 bashcompletiondir = $(sysconfdir)/bash_completion.d